summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dave Woodfall2021-05-03 07:48:48 +0200
committer Robby Workman2021-05-03 08:49:56 +0200
commit24da8b89415d43a711dedef83848ad656ef32d40 (patch)
treef71cdb1318e490ce41882a49cc769100771c283a /python
parente5286256a9fd41c98637113ff48617051fcaec3f (diff)
downloadslackbuilds-24da8b89415d43a711dedef83848ad656ef32d40.tar.gz
python/python-MonthDelta: Renamed python2-MonthDelta.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-MonthDelta/slack-desc19
-rw-r--r--python/python2-MonthDelta/README (renamed from python/python-MonthDelta/README)0
-rw-r--r--python/python2-MonthDelta/python2-MonthDelta.SlackBuild (renamed from python/python-MonthDelta/python-MonthDelta.SlackBuild)10
-rw-r--r--python/python2-MonthDelta/python2-MonthDelta.info (renamed from python/python-MonthDelta/python-MonthDelta.info)2
-rw-r--r--python/python2-MonthDelta/slack-desc19
5 files changed, 25 insertions, 25 deletions
diff --git a/python/python-MonthDelta/slack-desc b/python/python-MonthDelta/slack-desc
deleted file mode 100644
index e888cc40f1..0000000000
--- a/python/python-MonthDelta/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-MonthDelta: python-MonthDelta (Pythonic date calculation with months)
-python-MonthDelta:
-python-MonthDelta: Date computations with months
-python-MonthDelta:
-python-MonthDelta: Homepage: https://pypi.python.org/pypi/MonthDelta
-python-MonthDelta:
-python-MonthDelta:
-python-MonthDelta:
-python-MonthDelta:
-python-MonthDelta:
-python-MonthDelta:
diff --git a/python/python-MonthDelta/README b/python/python2-MonthDelta/README
index 35deb5aa0e..35deb5aa0e 100644
--- a/python/python-MonthDelta/README
+++ b/python/python2-MonthDelta/README
diff --git a/python/python-MonthDelta/python-MonthDelta.SlackBuild b/python/python2-MonthDelta/python2-MonthDelta.SlackBuild
index d253f53d50..a1bee56d2d 100644
--- a/python/python-MonthDelta/python-MonthDelta.SlackBuild
+++ b/python/python2-MonthDelta/python2-MonthDelta.SlackBuild
@@ -22,7 +22,7 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-PRGNAM=python-MonthDelta
+PRGNAM=python2-MonthDelta
VERSION=${VERSION:-1.0b}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -31,7 +31,7 @@ SRCNAM=$(echo $PRGNAM | cut -d- -f2)
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -42,8 +42,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -71,7 +71,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-MonthDelta/python-MonthDelta.info b/python/python2-MonthDelta/python2-MonthDelta.info
index 1848702ac3..ccb56ec6fb 100644
--- a/python/python-MonthDelta/python-MonthDelta.info
+++ b/python/python2-MonthDelta/python2-MonthDelta.info
@@ -1,4 +1,4 @@
-PRGNAM="python-MonthDelta"
+PRGNAM="python2-MonthDelta"
VERSION="1.0b"
HOMEPAGE="https://pypi.python.org/pypi/MonthDelta"
DOWNLOAD="https://pypi.python.org/packages/source/M/MonthDelta/MonthDelta-1.0b.tar.gz"
diff --git a/python/python2-MonthDelta/slack-desc b/python/python2-MonthDelta/slack-desc
new file mode 100644
index 0000000000..d9dc7b290d
--- /dev/null
+++ b/python/python2-MonthDelta/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-MonthDelta: python2-MonthDelta (Pythonic date calculation with months)
+python2-MonthDelta:
+python2-MonthDelta: Date computations with months
+python2-MonthDelta:
+python2-MonthDelta: Homepage: https://pypi.python.org/pypi/MonthDelta
+python2-MonthDelta:
+python2-MonthDelta:
+python2-MonthDelta:
+python2-MonthDelta:
+python2-MonthDelta:
+python2-MonthDelta: