summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author B. Watson2021-12-09 20:00:48 +0100
committer Willy Sudiarto Raharjo2021-12-10 02:37:39 +0100
commit1c3bce76b2131a0610bdca3c1a1918eea8b60adc (patch)
treebe644c188cc89bc0a6e001eb70657d8bf8f0c158 /python
parent0d08f123dcdb761a49d22f610e5fc56fdbf0b25f (diff)
downloadslackbuilds-1c3bce76b2131a0610bdca3c1a1918eea8b60adc.tar.gz
python/gmpy: Removed (no dependees).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/gmpy/README4
-rw-r--r--python/gmpy/gmpy.SlackBuild78
-rw-r--r--python/gmpy/gmpy.info10
-rw-r--r--python/gmpy/slack-desc19
4 files changed, 0 insertions, 111 deletions
diff --git a/python/gmpy/README b/python/gmpy/README
deleted file mode 100644
index d78b639ebd..0000000000
--- a/python/gmpy/README
+++ /dev/null
@@ -1,4 +0,0 @@
-gmpy (multi-precision arithmetic for python)
-
-gmpy is a C-coded Python extension module that provides access to the
-GMP multiple-precision arithmetic library.
diff --git a/python/gmpy/gmpy.SlackBuild b/python/gmpy/gmpy.SlackBuild
deleted file mode 100644
index 32619b1fb8..0000000000
--- a/python/gmpy/gmpy.SlackBuild
+++ /dev/null
@@ -1,78 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for gmpy
-
-# Written by B. Watson (yalhcru@gmail.com)
-
-# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=gmpy
-VERSION=${VERSION:-1.17}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-unzip $CWD/$PRGNAM-$VERSION.zip
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-strip $PKG/usr/lib*/python*/site-packages/*.so
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG-INFO README changes.txt lgpl-2.1.txt mutable_mpz.txt \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/gmpy/gmpy.info b/python/gmpy/gmpy.info
deleted file mode 100644
index 8b0329f3a0..0000000000
--- a/python/gmpy/gmpy.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="gmpy"
-VERSION="1.17"
-HOMEPAGE="https://github.com/aleaxit/gmpy"
-DOWNLOAD="https://pypi.python.org/packages/source/g/gmpy/gmpy-1.17.zip"
-MD5SUM="2bf419076b06e107167e219f60ac6d27"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
diff --git a/python/gmpy/slack-desc b/python/gmpy/slack-desc
deleted file mode 100644
index 06920c6e18..0000000000
--- a/python/gmpy/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-gmpy: gmpy (multi-precision arithmetic for python)
-gmpy:
-gmpy: gmpy is a C-coded Python extension module that provides access to
-gmpy: the GMP multiple-precision arithmetic library.
-gmpy:
-gmpy:
-gmpy:
-gmpy:
-gmpy:
-gmpy:
-gmpy: