summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2018-04-17 02:07:40 +0200
committer Willy Sudiarto Raharjo2018-04-21 02:43:04 +0200
commit91afa72e6c5a0cb9b7d57c204f2d342ffed6b844 (patch)
treeaba84eaf8ac488f9255e0c2a4cdae046d7b9bd9a /python
parent951c2c3d1b9d6bd2fe864f78894153e8886580cc (diff)
downloadslackbuilds-91afa72e6c5a0cb9b7d57c204f2d342ffed6b844.tar.gz
python/python3-decorator: Updated for version 4.3.0.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'python')
-rw-r--r--python/python3-decorator/python3-decorator.SlackBuild16
-rw-r--r--python/python3-decorator/python3-decorator.info6
2 files changed, 12 insertions, 10 deletions
diff --git a/python/python3-decorator/python3-decorator.SlackBuild b/python/python3-decorator/python3-decorator.SlackBuild
index a7c7e5ef92..d23a93ab03 100644
--- a/python/python3-decorator/python3-decorator.SlackBuild
+++ b/python/python3-decorator/python3-decorator.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for python3-decorator
# Copyright 2013 Mikko Värri, Finland
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
SRCNAM=decorator
PRGNAM=python3-$SRCNAM
-VERSION=${VERSION:-4.2.1}
+VERSION=${VERSION:-4.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -52,15 +52,17 @@ tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.md LICENSE.txt docs/README.rst $PKG/usr/doc/$PRGNAM-$VERSION/
+cp -a \
+ CHANGES.md LICENSE.txt docs/README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-decorator/python3-decorator.info b/python/python3-decorator/python3-decorator.info
index 49aa5f0e4b..e73bd6d40a 100644
--- a/python/python3-decorator/python3-decorator.info
+++ b/python/python3-decorator/python3-decorator.info
@@ -1,8 +1,8 @@
PRGNAM="python3-decorator"
-VERSION="4.2.1"
+VERSION="4.3.0"
HOMEPAGE="https://pypi.python.org/pypi/decorator"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/d/decorator/decorator-4.2.1.tar.gz"
-MD5SUM="e886337e9f70e70d45d67266b8e66044"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/d/decorator/decorator-4.3.0.tar.gz"
+MD5SUM="249e7299b9b4bced0c382343f84eb1c0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3"