summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Andrew Clemons2018-03-22 20:06:04 +0100
committer Willy Sudiarto Raharjo2018-03-31 02:41:43 +0200
commit816a6642a6fcc0c3465796649f3a7a0e7f973c93 (patch)
tree562e4de60d2c54a3bf98055c3a4a72e73dec00fc /python
parentccba12d99252e7f98d8d78ea7b7e2ecd3d066d1b (diff)
downloadslackbuilds-816a6642a6fcc0c3465796649f3a7a0e7f973c93.tar.gz
python/git-fame: Updated for version 1.4.2.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com>
Diffstat (limited to 'python')
-rw-r--r--python/git-fame/git-fame.SlackBuild7
-rw-r--r--python/git-fame/git-fame.info8
2 files changed, 9 insertions, 6 deletions
diff --git a/python/git-fame/git-fame.SlackBuild b/python/git-fame/git-fame.SlackBuild
index 4ac22ea1bf..b3204c85b2 100644
--- a/python/git-fame/git-fame.SlackBuild
+++ b/python/git-fame/git-fame.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for git-fame
-# Copyright 2017 Andrew Clemons, Wellington New Zealand
+# Copyright 2017-2018 Andrew Clemons, Wellington New Zealand
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=git-fame
-VERSION=${VERSION:-1.3.0}
+VERSION=${VERSION:-1.4.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -74,6 +74,9 @@ python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
mkdir -p $PKG/usr/share/bash-completion/completions
install -m 644 git-fame_completion.bash $PKG/usr/share/bash-completion/completions/git-fame
diff --git a/python/git-fame/git-fame.info b/python/git-fame/git-fame.info
index f5fd02d498..337cfc5b7d 100644
--- a/python/git-fame/git-fame.info
+++ b/python/git-fame/git-fame.info
@@ -1,10 +1,10 @@
PRGNAM="git-fame"
-VERSION="1.3.0"
+VERSION="1.4.2"
HOMEPAGE="https://pypi.python.org/pypi/git-fame"
-DOWNLOAD="https://pypi.python.org/packages/18/3a/770ecab7f5dab76bd684cef156caa52e028984a44f3fe873379c0893fa74/git-fame-1.3.0.tar.gz"
-MD5SUM="81229251cf92077b47084a4158bf1488"
+DOWNLOAD="https://pypi.python.org/packages/8b/0f/dfb31752f4df3e0d5561efff4b7965614f1e47fe64ee65cf98e6e80e09cb/git-fame-1.4.2.tar.gz#md5=jbj"
+MD5SUM="9ea9eee26a511ff569af786a19008678"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="docopt tqdm"
+REQUIRES="python-argopt docopt tqdm"
MAINTAINER="Andrew Clemons"
EMAIL="andrew.clemons@gmail.com"