summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis2018-04-08 17:58:54 +0200
committer Willy Sudiarto Raharjo2018-04-14 02:06:27 +0200
commit2dd769a2febb07d429d838d9cd736b16589a73f6 (patch)
treea95d10603c0257280a0f86c323c1479d9e5b3f36 /python
parenta38084054d66a774dbdf03362b4e1b010f01bb78 (diff)
downloadslackbuilds-2dd769a2febb07d429d838d9cd736b16589a73f6.tar.gz
python/setuptools-scm-git-archive: Added (setuptools_scm plugin).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/setuptools-scm-git-archive/README2
-rw-r--r--python/setuptools-scm-git-archive/setuptools-scm-git-archive.SlackBuild86
-rw-r--r--python/setuptools-scm-git-archive/setuptools-scm-git-archive.info10
-rw-r--r--python/setuptools-scm-git-archive/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/python/setuptools-scm-git-archive/README b/python/setuptools-scm-git-archive/README
new file mode 100644
index 0000000000..84da17fa9e
--- /dev/null
+++ b/python/setuptools-scm-git-archive/README
@@ -0,0 +1,2 @@
+This is a setuptools_scm plugin that adds support for git archives (for example
+the ones GitHub automatically generates).
diff --git a/python/setuptools-scm-git-archive/setuptools-scm-git-archive.SlackBuild b/python/setuptools-scm-git-archive/setuptools-scm-git-archive.SlackBuild
new file mode 100644
index 0000000000..db7f281481
--- /dev/null
+++ b/python/setuptools-scm-git-archive/setuptools-scm-git-archive.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for setuptools-scm-git-archive
+
+# Copyright 2018 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=setuptools-scm-git-archive
+SRCNAM=$(echo $PRGNAM | tr - _)
+VERSION=${VERSION:-1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst LICENSE PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/setuptools-scm-git-archive/setuptools-scm-git-archive.info b/python/setuptools-scm-git-archive/setuptools-scm-git-archive.info
new file mode 100644
index 0000000000..6c96271b45
--- /dev/null
+++ b/python/setuptools-scm-git-archive/setuptools-scm-git-archive.info
@@ -0,0 +1,10 @@
+PRGNAM="setuptools-scm-git-archive"
+VERSION="1.0"
+HOMEPAGE="https://github.com/Changaco/setuptools_scm_git_archive/"
+DOWNLOAD="https://pypi.python.org/packages/18/00/754438f629dfff1ecdbb31c8c23effe8bcfdbf65dbaf1cbed58eab286d82/setuptools_scm_git_archive-1.0.tar.gz"
+MD5SUM="cb4ca99e97edea548117fe0d80cbd089"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="setuptools-scm"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/setuptools-scm-git-archive/slack-desc b/python/setuptools-scm-git-archive/slack-desc
new file mode 100644
index 0000000000..1519bab18c
--- /dev/null
+++ b/python/setuptools-scm-git-archive/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+setuptools-scm-git-archive: setuptools-scm-git-archive (setuptools_scm plugin for git archives)
+setuptools-scm-git-archive:
+setuptools-scm-git-archive: This is a setuptools_scm plugin that adds support for git archives
+setuptools-scm-git-archive: (for example the ones GitHub automatically generates).
+setuptools-scm-git-archive:
+setuptools-scm-git-archive: Homepage: https://github.com/Changaco/setuptools_scm_git_archive/
+setuptools-scm-git-archive:
+setuptools-scm-git-archive:
+setuptools-scm-git-archive:
+setuptools-scm-git-archive:
+setuptools-scm-git-archive: