summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Markus Rinne2018-04-18 11:50:44 +0200
committer Willy Sudiarto Raharjo2018-04-21 02:43:00 +0200
commit25ea671171009609e0cf76d7f26df9b292fc85c2 (patch)
tree881ff1be6f0b75b41d0e88fdc277aa96394645cb /python
parentfbe026ca33e0e7f3c2e44b1ccd87e2916d8eb5d3 (diff)
downloadslackbuilds-25ea671171009609e0cf76d7f26df9b292fc85c2.tar.gz
python/pycryptodome: Added (Python Cryptography Toolkit).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pycryptodome/README8
-rw-r--r--python/pycryptodome/pycryptodome.SlackBuild87
-rw-r--r--python/pycryptodome/pycryptodome.info10
-rw-r--r--python/pycryptodome/slack-desc19
4 files changed, 124 insertions, 0 deletions
diff --git a/python/pycryptodome/README b/python/pycryptodome/README
new file mode 100644
index 0000000000..7b818930c5
--- /dev/null
+++ b/python/pycryptodome/README
@@ -0,0 +1,8 @@
+PyCryptodome is a self-contained Python package of low-level cryptographic
+primitives. It supports Python 2.6 or newer, all Python 3 versions and PyPy.
+PyCryptodome is a fork of PyCrypto.
+
+PyCryptodome is not a wrapper to a separate C library like OpenSSL. To the
+largest possible extent, algorithms are implemented in pure Python. Only the
+pieces that are extremely critical to performance (e.g. block ciphers) are
+implemented as C extensions.
diff --git a/python/pycryptodome/pycryptodome.SlackBuild b/python/pycryptodome/pycryptodome.SlackBuild
new file mode 100644
index 0000000000..d6d025bb60
--- /dev/null
+++ b/python/pycryptodome/pycryptodome.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for pycryptodome
+
+# Copyright 2018 Markus Rinne Finland
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pycryptodome
+VERSION=${VERSION:-3.6.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-${VERSION}x
+tar xvf $CWD/$PRGNAM-${VERSION}x.tar.gz
+cd $PRGNAM-${VERSION}x
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS.rst Changelog.rst FuturePlans.rst INSTALL.rst LICENSE.rst README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pycryptodome/pycryptodome.info b/python/pycryptodome/pycryptodome.info
new file mode 100644
index 0000000000..6f21da9ebf
--- /dev/null
+++ b/python/pycryptodome/pycryptodome.info
@@ -0,0 +1,10 @@
+PRGNAM="pycryptodome"
+VERSION="3.6.1"
+HOMEPAGE="https://github.com/Legrandin/pycryptodome"
+DOWNLOAD="https://github.com/Legrandin/pycryptodome/archive/v3.6.1x/pycryptodome-3.6.1x.tar.gz"
+MD5SUM="569c44646fe345d8d262ac97a3c97895"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Markus Rinne"
+EMAIL="markus.ka.rinne@gmail.com"
diff --git a/python/pycryptodome/slack-desc b/python/pycryptodome/slack-desc
new file mode 100644
index 0000000000..987d2c3dfe
--- /dev/null
+++ b/python/pycryptodome/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pycryptodome: pycryptodome (Python Cryptography Toolkit)
+pycryptodome:
+pycryptodome: PyCryptodome is a self-contained Python package of low-level
+pycryptodome: cryptographic primitives. It supports Python 2.6 or newer, all
+pycryptodome: Python 3 versions and PyPy. PyCryptodome is a fork of PyCrypto.
+pycryptodome:
+pycryptodome: PyCryptodome is not a wrapper to a separate C library like OpenSSL.
+pycryptodome: To the largest possible extent, algorithms are implemented in pure
+pycryptodome: Python. Only the pieces that are extremely critical to performance
+pycryptodome: (e.g. block ciphers) are implemented as C extensions.
+pycryptodome: