summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Fernando Lopez Jr2018-01-08 14:02:27 +0100
committer David Spencer2018-01-08 14:02:27 +0100
commitd57b3fff4822983a98a21fd361b98a5b2ff63cad (patch)
tree05fe9a7d6ec869d31a4209ba8f78dbdf7b75f4f7 /python
parentf3fea40b5c74f2c59dfbecfc82cea1fe8f7bbdfc (diff)
downloadslackbuilds-d57b3fff4822983a98a21fd361b98a5b2ff63cad.tar.gz
python/networkx: Added (create and manipulate networks).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/networkx/README3
-rw-r--r--python/networkx/networkx.SlackBuild94
-rw-r--r--python/networkx/networkx.info10
-rw-r--r--python/networkx/slack-desc19
4 files changed, 126 insertions, 0 deletions
diff --git a/python/networkx/README b/python/networkx/README
new file mode 100644
index 0000000000..4c00f24f83
--- /dev/null
+++ b/python/networkx/README
@@ -0,0 +1,3 @@
+NetworkX is a Python package for the creation, manipulation,
+and study of the structure, dynamics, and functions of complex
+networks.
diff --git a/python/networkx/networkx.SlackBuild b/python/networkx/networkx.SlackBuild
new file mode 100644
index 0000000000..71fa9257bc
--- /dev/null
+++ b/python/networkx/networkx.SlackBuild
@@ -0,0 +1,94 @@
+#!/bin/sh
+
+# Slackware build script for networkx
+
+# Copyright 2016 Fernando Lopez Jr. <fernando.lopezjr@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=networkx
+VERSION=${VERSION:-2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$VERSION.zip
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i -e 's:share/doc:doc:' setup.py
+
+python setup.py install --root=$PKG
+
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE.txt INSTALL.rst CONTRIBUTING.rst CONTRIBUTORS.rst README.rst RELEASE.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/networkx/networkx.info b/python/networkx/networkx.info
new file mode 100644
index 0000000000..5ee14cc0c1
--- /dev/null
+++ b/python/networkx/networkx.info
@@ -0,0 +1,10 @@
+PRGNAM="networkx"
+VERSION="2.0"
+HOMEPAGE="http://networkx.github.io/"
+DOWNLOAD="https://pypi.python.org/packages/73/58/0add7d81cf64958f7a062aa287237364eb0a0959bf7a817f708d5c25d043/networkx-2.0.zip"
+MD5SUM="34f9cc01b2eca37f362673b8eb65316b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Fernando Lopez Jr."
+EMAIL="fernando.lopezjr@gmail.com"
diff --git a/python/networkx/slack-desc b/python/networkx/slack-desc
new file mode 100644
index 0000000000..a330321184
--- /dev/null
+++ b/python/networkx/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+networkx: networkx (create, manipulate and study complex networks)
+networkx:
+networkx: NetworkX is a Python package for the creation, manipulation,
+networkx: and study of the structure, dynamics, and functions of complex
+networkx: networks.
+networkx:
+networkx:
+networkx:
+networkx:
+networkx:
+networkx: