summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2018-01-04 02:19:56 +0100
committer Willy Sudiarto Raharjo2018-01-06 00:43:39 +0100
commitbdd19f29696dc845c1a6d942970a7cedefbea943 (patch)
treeec2d150dec9e83d4d21686c5f5f586ccb854fd54 /python
parentbb6badf9a52310c97b181b7adf3d833ff1732a42 (diff)
downloadslackbuilds-bdd19f29696dc845c1a6d942970a7cedefbea943.tar.gz
python/python-jsonrpclib: Updated for version 0.3.1.
This also add python3 support. Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-jsonrpclib/python-jsonrpclib.SlackBuild10
-rw-r--r--python/python-jsonrpclib/python-jsonrpclib.info8
-rw-r--r--python/python-jsonrpclib/slack-desc2
3 files changed, 12 insertions, 8 deletions
diff --git a/python/python-jsonrpclib/python-jsonrpclib.SlackBuild b/python/python-jsonrpclib/python-jsonrpclib.SlackBuild
index e2fecf6b1c..d8e9d8720a 100644
--- a/python/python-jsonrpclib/python-jsonrpclib.SlackBuild
+++ b/python/python-jsonrpclib/python-jsonrpclib.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-jsonrpclib
-# Copyright 2016 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2016-2018 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=python-jsonrpclib
SRCNAM=jsonrpclib
-VERSION=${VERSION:-0.1.7}
+VERSION=${VERSION:-0.3.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -55,7 +55,7 @@ else
LIBDIRSUFFIX=""
fi
-set -e
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -72,6 +72,10 @@ find -L . \
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-jsonrpclib/python-jsonrpclib.info b/python/python-jsonrpclib/python-jsonrpclib.info
index d706d0746e..f3b3a28b7d 100644
--- a/python/python-jsonrpclib/python-jsonrpclib.info
+++ b/python/python-jsonrpclib/python-jsonrpclib.info
@@ -1,8 +1,8 @@
PRGNAM="python-jsonrpclib"
-VERSION="0.1.7"
-HOMEPAGE="https://github.com/joshmarshall/jsonrpclib/"
-DOWNLOAD="https://github.com/joshmarshall/jsonrpclib/archive/v0.1.7.tar.gz"
-MD5SUM="a071d3bb3f56b9bce4e3740f87784b0a"
+VERSION="0.3.1"
+HOMEPAGE="https://github.com/tcalmant/jsonrpclib"
+DOWNLOAD="https://github.com/tcalmant/jsonrpclib/archive/v0.3.1/jsonrpclib-0.3.1.tar.gz"
+MD5SUM="42f2f07d8d1b5badc33b7f1aebe6f36f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/python/python-jsonrpclib/slack-desc b/python/python-jsonrpclib/slack-desc
index 1cf4dc25e9..130d6fa044 100644
--- a/python/python-jsonrpclib/slack-desc
+++ b/python/python-jsonrpclib/slack-desc
@@ -15,5 +15,5 @@ python-jsonrpclib: (proposed) 2.0 spec, which includes batch submission, keyword
python-jsonrpclib: arguments, etc.
python-jsonrpclib:
python-jsonrpclib:
-python-jsonrpclib: Project URL: https://github.com/joshmarshall/jsonrpclib
+python-jsonrpclib: Project URL: https://github.com/tcalmant/jsonrpclib
python-jsonrpclib: