summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2018-01-04 02:16:24 +0100
committer Willy Sudiarto Raharjo2018-01-04 02:16:24 +0100
commitbb86a5c08149834695fc74886bdf340b23d65a5a (patch)
tree1be83c522925f0641c42dece6fd776e7885eff65 /python
parent8a7492b2ff2bf96801ca74f42f1cb8caba728189 (diff)
downloadslackbuilds-bb86a5c08149834695fc74886bdf340b23d65a5a.tar.gz
python/python-pbkdf2: Add python3 support.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-pbkdf2/python-pbkdf2.SlackBuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/python/python-pbkdf2/python-pbkdf2.SlackBuild b/python/python-pbkdf2/python-pbkdf2.SlackBuild
index a6c1df1f14..74a33fa1e8 100644
--- a/python/python-pbkdf2/python-pbkdf2.SlackBuild
+++ b/python/python-pbkdf2/python-pbkdf2.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-pbkdf2
-# Copyright 2015-2016 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2015-2018 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -54,7 +54,7 @@ else
LIBDIRSUFFIX=""
fi
-set -e
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -71,6 +71,10 @@ find -L . \
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true