summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2018-01-10 00:11:59 +0100
committer Willy Sudiarto Raharjo2018-01-10 17:55:49 +0100
commita849b171fe0b7e6529dd54383653944718ce547c (patch)
tree3cef40a263f1d567c036c24f470096fcf32fedde /python
parent77086740919a079fcf2fb64d2a4a4742bcb590a8 (diff)
downloadslackbuilds-a849b171fe0b7e6529dd54383653944718ce547c.tar.gz
python/google-apputils: Add python3 support.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/google-apputils/google-apputils.SlackBuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/python/google-apputils/google-apputils.SlackBuild b/python/google-apputils/google-apputils.SlackBuild
index b808fa68e9..96fd672f4b 100644
--- a/python/google-apputils/google-apputils.SlackBuild
+++ b/python/google-apputils/google-apputils.SlackBuild
@@ -57,6 +57,10 @@ find -L . \
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true