summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Fernando Lopez Jr2017-11-13 18:33:35 +0100
committer Willy Sudiarto Raharjo2017-11-18 06:40:24 +0100
commit266462074adc4c6c1d558c3795ab85d3eb8c4a6f (patch)
tree32d9f916ae3452fc4910d943da09bea2522ab34f /python
parent3bb6c5a2af9f1a7bc734d1911313352c5eb7927b (diff)
downloadslackbuilds-266462074adc4c6c1d558c3795ab85d3eb8c4a6f.tar.gz
python/responder: Added (LLMNR, NBT-NS and MDNS poisoner).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/responder/README11
-rw-r--r--python/responder/responder.SlackBuild94
-rw-r--r--python/responder/responder.info10
-rw-r--r--python/responder/setup.py14
-rw-r--r--python/responder/slack-desc19
5 files changed, 148 insertions, 0 deletions
diff --git a/python/responder/README b/python/responder/README
new file mode 100644
index 0000000000..e8f9942b9b
--- /dev/null
+++ b/python/responder/README
@@ -0,0 +1,11 @@
+Responder is an LLMNR, NBT-NS and MDNS poisoner. It will answer to
+specific NBT-NS (NetBIOS Name Service) queries based on their name
+suffix (see: http://support.microsoft.com/kb/163409). By default, the
+tool will only answer to File Server Service request, which is for SMB.
+
+The concept behind this is to target our answers, and be stealthier on
+the network. This also helps to ensure that we don't break legitimate
+NBT-NS behavior. You can set the -r option via command line if you want
+to answer to the Workstation Service request name suffix.
+
+Optional dependency: python3
diff --git a/python/responder/responder.SlackBuild b/python/responder/responder.SlackBuild
new file mode 100644
index 0000000000..e7274592b3
--- /dev/null
+++ b/python/responder/responder.SlackBuild
@@ -0,0 +1,94 @@
+#!/bin/sh
+
+# Slackware build script for responder
+
+# Copyright 2016 Fernando Lopez Jr. <fernando.lopezjr@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=responder
+SRCNAM=Responder
+VERSION=${VERSION:-2.3.3.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+cp $CWD/setup.py .
+python setup.py install --root=$PKG
+
+# Python 3 support.
+if python3 -c 'import sys' 2>/dev/null; then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.md LICENSE \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/responder/responder.info b/python/responder/responder.info
new file mode 100644
index 0000000000..ef3a63f5c6
--- /dev/null
+++ b/python/responder/responder.info
@@ -0,0 +1,10 @@
+PRGNAM="responder"
+VERSION="2.3.3.8"
+HOMEPAGE="https://github.com/lgandx/Responder"
+DOWNLOAD="https://github.com/lgandx/Responder/archive/v2.3.3.8/Responder-2.3.3.8.tar.gz"
+MD5SUM="e22240e0d0849bc9ab4e9b56e46c4c86"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Fernando Lopez Jr."
+EMAIL="fernando.lopezjr@gmail.com"
diff --git a/python/responder/setup.py b/python/responder/setup.py
new file mode 100644
index 0000000000..c030cba557
--- /dev/null
+++ b/python/responder/setup.py
@@ -0,0 +1,14 @@
+#from distutils.core import setup
+from setuptools import setup
+
+setup(
+ name='responder',
+ version='2.3.3.8',
+ description='LLMNR/NBT-NS/mDNS Poisoner and NTLMv1/2 Relay',
+ author='Laurent Gaffie',
+ author_email='laurent.gaffie@gmail.com',
+ license='GPLv3',
+ url='https://github.com/lgandx/Responder/',
+ long_description=open('README.md').read(),
+ packages=['certs','files','logs','poisoners','servers','tools','tools.MultiRelay','tools.SMBFinger',],
+)
diff --git a/python/responder/slack-desc b/python/responder/slack-desc
new file mode 100644
index 0000000000..c6f3b0efaa
--- /dev/null
+++ b/python/responder/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+responder: responder (LLMNR, NBT-NS and MDNS poisoner)
+responder:
+responder: Responder is an LLMNR, NBT-NS and MDNS poisoner. It will answer to
+responder: specific NBT-NS (NetBIOS Name Service) queries based on their name
+responder: suffix (see: http://support.microsoft.com/kb/163409).
+responder: By default, the tool will only answer to File Server Service request,
+responder: which is for SMB.
+responder:
+responder:
+responder:
+responder: