summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2018-01-10 00:27:34 +0100
committer Willy Sudiarto Raharjo2018-01-10 17:55:50 +0100
commit2360f7ccbeeddbb90fb882752c2abbe77c8d10e8 (patch)
tree5a1bc3f426f27edc87f10e5be39c76ecf654063e /python
parent7ad79080d1548774276f328e873f007cfc794224 (diff)
downloadslackbuilds-2360f7ccbeeddbb90fb882752c2abbe77c8d10e8.tar.gz
python/pyasn1: Add python3 support.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pyasn1/pyasn1.SlackBuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/python/pyasn1/pyasn1.SlackBuild b/python/pyasn1/pyasn1.SlackBuild
index 04937b6c32..e6b7eb6a69 100644
--- a/python/pyasn1/pyasn1.SlackBuild
+++ b/python/pyasn1/pyasn1.SlackBuild
@@ -73,6 +73,11 @@ find -L . \
python setup.py install --root=$PKG
+# Add Python3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true