summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author David Spencer2016-08-30 23:24:39 +0200
committer Willy Sudiarto Raharjo2016-08-30 23:24:39 +0200
commit45b42e01e93d1c73a755f8a85cd658748513b340 (patch)
tree77922a5a73e018181610f83c815f0343654f028a /python
parent5f0c2f5c1928a68163b9cc5813e5f5b9c612bd19 (diff)
downloadslackbuilds-45b42e01e93d1c73a755f8a85cd658748513b340.tar.gz
python/buildbot: Added (automated compile/test cycle).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/buildbot/README12
-rw-r--r--python/buildbot/buildbot.SlackBuild87
-rw-r--r--python/buildbot/buildbot.info10
-rw-r--r--python/buildbot/slack-desc19
4 files changed, 128 insertions, 0 deletions
diff --git a/python/buildbot/README b/python/buildbot/README
new file mode 100644
index 0000000000..f8cf037869
--- /dev/null
+++ b/python/buildbot/README
@@ -0,0 +1,12 @@
+The BuildBot is a system to automate the compile/test cycle required by most
+software projects to validate code changes. By automatically rebuilding and
+testing the tree each time something has changed, build problems are pinpointed
+quickly, before other developers are inconvenienced by the failure. The guilty
+developer can be identified and harassed without human intervention. By running
+the builds on a variety of platforms, developers who do not have the facilities
+to test their changes everywhere before checkin will at least know shortly
+afterwards whether they have broken the build or not. Warning counts, lint
+checks, image size, compile time, and other build parameters can be tracked
+over time, are more visible, and are therefore easier to improve.
+
+See also buildbot-slave (the slave component of BuildBot).
diff --git a/python/buildbot/buildbot.SlackBuild b/python/buildbot/buildbot.SlackBuild
new file mode 100644
index 0000000000..b94ceaa0e6
--- /dev/null
+++ b/python/buildbot/buildbot.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for buildbot
+
+# Copyright 2016 David Spencer, Baildon, West Yorkshire, U.K.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=buildbot
+VERSION=${VERSION:-0.8.14}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/man/man1
+gzip -9 < docs/buildbot.1 > $PKG/usr/man/man1/buildbot.1.gz
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING CREDITS NEWS README UPGRADING \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/buildbot/buildbot.info b/python/buildbot/buildbot.info
new file mode 100644
index 0000000000..ff4f3c2821
--- /dev/null
+++ b/python/buildbot/buildbot.info
@@ -0,0 +1,10 @@
+PRGNAM="buildbot"
+VERSION="0.8.14"
+HOMEPAGE="http://buildbot.net/"
+DOWNLOAD="https://pypi.python.org/packages/39/19/c8f8845d302b7df9d44a86a00911ccd12c0f8835bd6c562ae57b826fda29/buildbot-0.8.14.tar.gz"
+MD5SUM="a915481515675800448d3e6a99a15e14"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python-dateutil Jinja2 sqlalchemy-migrate sqlparse python-twisted"
+MAINTAINER="David Spencer"
+EMAIL="baildon.research@googlemail.com"
diff --git a/python/buildbot/slack-desc b/python/buildbot/slack-desc
new file mode 100644
index 0000000000..e5421f3f5d
--- /dev/null
+++ b/python/buildbot/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+buildbot: buildbot (automated compile/test cycle)
+buildbot:
+buildbot: BuildBot is a system to automate the compile/test cycle required by
+buildbot: most software projects.
+buildbot:
+buildbot:
+buildbot:
+buildbot:
+buildbot:
+buildbot:
+buildbot: