summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Larry Hajali2015-12-31 01:08:45 +0100
committer Willy Sudiarto Raharjo2015-12-31 01:08:45 +0100
commitde92c20892abb7d907c1c403810ab2153af9c542 (patch)
tree356bbcff47b5be09fc24af013ecd8b40fa7c5091 /python
parent9b0240ebe714fd4b04918e0785f2d7afc7e3719e (diff)
downloadslackbuilds-de92c20892abb7d907c1c403810ab2153af9c542.tar.gz
python/filechunkio: Updated for version 1.6.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/filechunkio/README6
-rw-r--r--python/filechunkio/filechunkio.SlackBuild35
-rw-r--r--python/filechunkio/filechunkio.info6
3 files changed, 38 insertions, 9 deletions
diff --git a/python/filechunkio/README b/python/filechunkio/README
index ff5f847a24..0e5c84bb1c 100644
--- a/python/filechunkio/README
+++ b/python/filechunkio/README
@@ -1,3 +1,9 @@
FileChunkIO is a way to upload huge files to Amazon S3 in multiple parts without
having to split them physically upfront (which requires more time and twice the
disk space) or creating in-memory chunks as StringIO instances.
+
+Optionanl: python3
+
+Note: To install python3 bindings install python3 and run script with PYTHON3=yes.
+
+ # PYTHON3=yes ./filechunkio.SlackBuild
diff --git a/python/filechunkio/filechunkio.SlackBuild b/python/filechunkio/filechunkio.SlackBuild
index ce74850a70..2f9be5dea5 100644
--- a/python/filechunkio/filechunkio.SlackBuild
+++ b/python/filechunkio/filechunkio.SlackBuild
@@ -2,10 +2,28 @@
# Slackware build script for filechunkio
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2011-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=filechunkio
-VERSION=${VERSION:-1.5}
+VERSION=${VERSION:-1.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -32,13 +50,18 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+# Install python3 modules. Default is no.
+if [ "${PYTHON3:-no}" == "yes" ]; then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/filechunkio/filechunkio.info b/python/filechunkio/filechunkio.info
index d235bc935d..55106abc1c 100644
--- a/python/filechunkio/filechunkio.info
+++ b/python/filechunkio/filechunkio.info
@@ -1,8 +1,8 @@
PRGNAM="filechunkio"
-VERSION="1.5"
+VERSION="1.6"
HOMEPAGE="https://bitbucket.org/fabian/filechunkio"
-DOWNLOAD="http://pypi.python.org/packages/source/f/filechunkio/filechunkio-1.5.tar.gz"
-MD5SUM="bdc8507116dc32c7f140ff76cfd09ecc"
+DOWNLOAD="http://pypi.python.org/packages/source/f/filechunkio/filechunkio-1.6.tar.gz"
+MD5SUM="c168a11ad94cd2ec42a219f0f8869a7b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""