summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2015-11-24 02:40:08 +0100
committer Willy Sudiarto Raharjo2015-11-28 01:25:59 +0100
commit802811f611ecba7197d006259850b224f72d8bf0 (patch)
tree450f60f2f01220ce3a1838a6c5ce3c8d0a3713c7 /python
parentc9a97773f8a0eb5e478348dc7a9dde8366ea0f5f (diff)
downloadslackbuilds-802811f611ecba7197d006259850b224f72d8bf0.tar.gz
python/python-ndg_httpsclient: Removed (duplicate).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-ndg_httpsclient/README4
-rw-r--r--python/python-ndg_httpsclient/python-ndg_httpsclient.SlackBuild85
-rw-r--r--python/python-ndg_httpsclient/python-ndg_httpsclient.info10
-rw-r--r--python/python-ndg_httpsclient/slack-desc19
4 files changed, 0 insertions, 118 deletions
diff --git a/python/python-ndg_httpsclient/README b/python/python-ndg_httpsclient/README
deleted file mode 100644
index bacd69bcb7..0000000000
--- a/python/python-ndg_httpsclient/README
+++ /dev/null
@@ -1,4 +0,0 @@
-This is a HTTPS client implementation for httplib and urllib2 based
-on PyOpenSSL. PyOpenSSL provides a more fully featured SSL
-implementation over the default provided with Python and importantly
-enables full verification of the SSL peer.
diff --git a/python/python-ndg_httpsclient/python-ndg_httpsclient.SlackBuild b/python/python-ndg_httpsclient/python-ndg_httpsclient.SlackBuild
deleted file mode 100644
index 89d631e017..0000000000
--- a/python/python-ndg_httpsclient/python-ndg_httpsclient.SlackBuild
+++ /dev/null
@@ -1,85 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-ndg_httpsclient
-
-# Copyright 2015 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-ndg_httpsclient
-SRCNAM=ndg_httpsclient
-VERSION=${VERSION:-0.4.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-ndg_httpsclient/python-ndg_httpsclient.info b/python/python-ndg_httpsclient/python-ndg_httpsclient.info
deleted file mode 100644
index 44aee9171c..0000000000
--- a/python/python-ndg_httpsclient/python-ndg_httpsclient.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-ndg_httpsclient"
-VERSION="0.4.0"
-HOMEPAGE="https://pypi.python.org/pypi/ndg-httpsclient"
-DOWNLOAD="https://pypi.python.org/packages/source/n/ndg-httpsclient/ndg_httpsclient-0.4.0.tar.gz"
-MD5SUM="81972c0267d5a47d678211ac854838f5"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pysetuptools"
-MAINTAINER="Willy Sudiarto Raharjo"
-EMAIL="willysr@slackbuilds.org"
diff --git a/python/python-ndg_httpsclient/slack-desc b/python/python-ndg_httpsclient/slack-desc
deleted file mode 100644
index c3f9d3eda7..0000000000
--- a/python/python-ndg_httpsclient/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-ndg_httpsclient: python-ndg_httpsclient (Python module)
-python-ndg_httpsclient:
-python-ndg_httpsclient: This is a HTTPS client implementation for httplib and urllib2 based
-python-ndg_httpsclient: on PyOpenSSL. PyOpenSSL provides a more fully featured SSL
-python-ndg_httpsclient: implementation over the default provided with Python and importantly
-python-ndg_httpsclient: enables full verification of the SSL peer.
-python-ndg_httpsclient:
-python-ndg_httpsclient:
-python-ndg_httpsclient: Project URL: https://pypi.python.org/pypi/ndg-httpsclient
-python-ndg_httpsclient:
-python-ndg_httpsclient: