summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Brenton Earl2015-11-14 17:16:34 +0100
committer Willy Sudiarto Raharjo2015-11-14 17:16:34 +0100
commit6a250f182ecd65acfcac96409f71010ba7cb04a6 (patch)
tree5a9d8abd6b6b6f2cfea0f7c73ae1b025cc36939e /python
parent1c2684f28287c93631e9f8a2a871bf06e9f777c6 (diff)
downloadslackbuilds-6a250f182ecd65acfcac96409f71010ba7cb04a6.tar.gz
python/python-futures: Added (Backport concurrent.futures package).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-futures/README3
-rw-r--r--python/python-futures/python-futures.SlackBuild91
-rw-r--r--python/python-futures/python-futures.info10
-rw-r--r--python/python-futures/slack-desc19
4 files changed, 123 insertions, 0 deletions
diff --git a/python/python-futures/README b/python/python-futures/README
new file mode 100644
index 0000000000..6d34208749
--- /dev/null
+++ b/python/python-futures/README
@@ -0,0 +1,3 @@
+Backport of the concurrent.futures package to Python 2.6 and 2.7.
+The concurrent.futures module provides a high-level interface for
+asynchronously executing callables.
diff --git a/python/python-futures/python-futures.SlackBuild b/python/python-futures/python-futures.SlackBuild
new file mode 100644
index 0000000000..eb9da7d282
--- /dev/null
+++ b/python/python-futures/python-futures.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for python-futures
+
+# Copyright 2015 Brenton Earl <brent@exitstatusone.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-futures
+SRCNAM=futures
+VERSION=${VERSION:-3.0.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES LICENSE PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# Add link to online documentation
+cat > $PKG/usr/doc/$PRGNAM-$VERSION/DOCS <<EOF
+Documentation: https://pythonhosted.org/futures/
+EOF
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-futures/python-futures.info b/python/python-futures/python-futures.info
new file mode 100644
index 0000000000..a66d90cd16
--- /dev/null
+++ b/python/python-futures/python-futures.info
@@ -0,0 +1,10 @@
+PRGNAM="python-futures"
+VERSION="3.0.3"
+HOMEPAGE="https://github.com/agronholm/pythonfutures"
+DOWNLOAD="https://pypi.python.org/packages/source/f/futures/futures-3.0.3.tar.gz"
+MD5SUM="32171f72af7e80c266310794adc4db46"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Brenton Earl"
+EMAIL="brent@exitstatusone.com"
diff --git a/python/python-futures/slack-desc b/python/python-futures/slack-desc
new file mode 100644
index 0000000000..d602cdd945
--- /dev/null
+++ b/python/python-futures/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-futures: python-futures (Backport of the concurrent.futures package)
+python-futures:
+python-futures: Backport of the concurrent.futures package to Python 2.6
+python-futures: and 2.7. The concurrent.futures module provides a high-level
+python-futures: interface for asynchronously executing callables.
+python-futures:
+python-futures: Home page: https://github.com/agronholm/pythonfutures
+python-futures:
+python-futures:
+python-futures:
+python-futures: