summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis2016-01-03 00:52:16 +0100
committer Willy Sudiarto Raharjo2016-01-09 01:12:22 +0100
commit2ca53b9427ed046492b3b6640765d583e980967b (patch)
tree7055fc29d6fb5bdbf03dc62bfcdcc27b5a8ce471 /python
parent0692437a1c4519fb27f59a3b47ad4c265b55a51d (diff)
downloadslackbuilds-2ca53b9427ed046492b3b6640765d583e980967b.tar.gz
python/python-keyutils: Added (keyutils bindings for Python).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-keyutils/README5
-rw-r--r--python/python-keyutils/python-keyutils.SlackBuild86
-rw-r--r--python/python-keyutils/python-keyutils.info10
-rw-r--r--python/python-keyutils/slack-desc19
4 files changed, 120 insertions, 0 deletions
diff --git a/python/python-keyutils/README b/python/python-keyutils/README
new file mode 100644
index 0000000000..4ec1441822
--- /dev/null
+++ b/python/python-keyutils/README
@@ -0,0 +1,5 @@
+python-keyutils is a set of python bindings for keyutils
+(available from http://people.redhat.com/~dhowells/keyutils),
+a key management suite that leverages the infrastructure
+provided by the Linux kernel for safely storing and retrieving
+sensitive infromation in your programs.
diff --git a/python/python-keyutils/python-keyutils.SlackBuild b/python/python-keyutils/python-keyutils.SlackBuild
new file mode 100644
index 0000000000..cd0df99fda
--- /dev/null
+++ b/python/python-keyutils/python-keyutils.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for python-keyutils
+
+# Copyright 2016 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-keyutils
+SRCNAM=$(echo $PRGNAM | cut -c8-15)
+VERSION=${VERSION:-0.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst ChangeLog LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-keyutils/python-keyutils.info b/python/python-keyutils/python-keyutils.info
new file mode 100644
index 0000000000..7f50fc1870
--- /dev/null
+++ b/python/python-keyutils/python-keyutils.info
@@ -0,0 +1,10 @@
+PRGNAM="python-keyutils"
+VERSION="0.3"
+HOMEPAGE="https://github.com/sassoftware/python-keyutils"
+DOWNLOAD="https://pypi.python.org/packages/source/k/keyutils/keyutils-0.3.tar.gz"
+MD5SUM="c3bf5836b3c7ee89170b2fa3886963b1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python-keyutils/slack-desc b/python/python-keyutils/slack-desc
new file mode 100644
index 0000000000..2540e2d88d
--- /dev/null
+++ b/python/python-keyutils/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-keyutils: python-keyutils (keyutils bindings for Python)
+python-keyutils:
+python-keyutils: python-keyutils is a set of python bindings for keyutils a key
+python-keyutils: management suite that leverages the infrastructure provided by
+python-keyutils: the Linux kernel for safely storing and retrieving sensitive
+python-keyutils: infromation in your programs.
+python-keyutils:
+python-keyutils: Homepage: https://github.com/sassoftware/python-keyutils
+python-keyutils:
+python-keyutils:
+python-keyutils: