summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Robby Workman2011-05-03 22:31:08 +0200
committer Robby Workman2011-05-03 22:31:08 +0200
commitaf5062470253b9afae7071c3cb8eab4f1e2c9c9b (patch)
tree2cfa6d9faaca9a1c2b92745342e5fb89c7f811d8 /python
parent9444e5a3ec1d2a86686becdabfbc14255420c498 (diff)
downloadslackbuilds-af5062470253b9afae7071c3cb8eab4f1e2c9c9b.tar.gz
python/pip: Moved from Development category
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pip/README26
-rw-r--r--python/pip/pip.SlackBuild49
-rw-r--r--python/pip/pip.info10
-rw-r--r--python/pip/slack-desc19
4 files changed, 104 insertions, 0 deletions
diff --git a/python/pip/README b/python/pip/README
new file mode 100644
index 0000000000..f2dbe460da
--- /dev/null
+++ b/python/pip/README
@@ -0,0 +1,26 @@
+pip is a replacement for easy_install (from pysetuptools). It uses mostly
+the same techniques for finding packages, so packages that were made
+easy_installable should be pip-installable as well.
+
+pip is meant to improve on easy_install. Some of the improvements:
+
+- All packages are downloaded before installation. Partially-completed
+ installation doesn't occur as a result.
+- Care is taken to present useful output on the console.
+- The reasons for actions are kept track of. For instance, if a package is
+ being installed, pip keeps track of why that package was required.
+- Error messages should be useful.
+- The code is relatively concise and cohesive, making it easier to use
+ programmatically.
+- Packages don't have to be installed as egg archives, they can be
+ installed flat (while keeping the egg metadata).
+- Native support for other version control systems (Git, Mercurial and
+ Bazaar).
+- Uninstallation of packages.
+- Simple to define fixed sets of requirements and reliably reproduce a set
+ of packages.
+
+pip is complementary with virtualenv (can be found at SBo), and it is
+encouraged that you use virtualenv to isolate your installation.
+
+pip requires pysetuptools.
diff --git a/python/pip/pip.SlackBuild b/python/pip/pip.SlackBuild
new file mode 100644
index 0000000000..c67e2a8484
--- /dev/null
+++ b/python/pip/pip.SlackBuild
@@ -0,0 +1,49 @@
+#!/bin/sh
+
+# Slackware build script for pip
+# Written by Audrius Kažukauskas <audrius@neutrino.lt>
+
+PRGNAM=pip
+VERSION=${VERSION:-0.8.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -eu
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a docs/*.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pip/pip.info b/python/pip/pip.info
new file mode 100644
index 0000000000..d199b7b0b1
--- /dev/null
+++ b/python/pip/pip.info
@@ -0,0 +1,10 @@
+PRGNAM="pip"
+VERSION="0.8.2"
+HOMEPAGE="http://pip.openplans.org/"
+DOWNLOAD="http://pypi.python.org/packages/source/p/pip/pip-0.8.2.tar.gz"
+MD5SUM="df1eca0abe7643d92b5222240bed15f6"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Audrius Kažukauskas"
+EMAIL="audrius@neutrino.lt"
+APPROVED="Niels Horn"
diff --git a/python/pip/slack-desc b/python/pip/slack-desc
new file mode 100644
index 0000000000..39dfde099f
--- /dev/null
+++ b/python/pip/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pip: pip (a better easy_install replacement)
+pip:
+pip: pip is a replacement for easy_install from pysetuptools.
+pip:
+pip: Homepage: http://pip.openplans.org/
+pip:
+pip:
+pip:
+pip:
+pip:
+pip: