summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Marcel Saegebarth2015-08-11 12:43:32 +0200
committer Willy Sudiarto Raharjo2015-08-11 18:25:31 +0200
commitadb07120d122ec69795e9e0d52206a06058af295 (patch)
tree6ab519700d147611b5d06b35cc597f855ebedcac /python
parentd5456e7291b3fa0f5c7f22a8f7348f29ebea88c7 (diff)
downloadslackbuilds-adb07120d122ec69795e9e0d52206a06058af295.tar.gz
python/python3-lhafile: Added (Python LHA archive extension).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-lhafile/README5
-rw-r--r--python/python3-lhafile/python3-lhafile.SlackBuild85
-rw-r--r--python/python3-lhafile/python3-lhafile.info10
-rw-r--r--python/python3-lhafile/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/python/python3-lhafile/README b/python/python3-lhafile/README
new file mode 100644
index 0000000000..ad9fda0525
--- /dev/null
+++ b/python/python3-lhafile/README
@@ -0,0 +1,5 @@
+This project is an updated version of the project found
+at http://trac.neotitans.net/wiki/lhafile.
+It is primarily used as a component in FS-UAE Launcher to index and
+extract files from .lha archives. The project consists of a Python
+package (lhafile) and a C extension for Python (lzhlib).
diff --git a/python/python3-lhafile/python3-lhafile.SlackBuild b/python/python3-lhafile/python3-lhafile.SlackBuild
new file mode 100644
index 0000000000..d92eb53da8
--- /dev/null
+++ b/python/python3-lhafile/python3-lhafile.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for "python3-lhafile".
+
+# Copyright 2014-2015 Marcel Saegebarth <marc@mos6581.de>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-lhafile
+SRCNAM=python-lhafile
+VERSION=${VERSION:-0.1.0fs4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING.txt README.txt VERSION $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-lhafile/python3-lhafile.info b/python/python3-lhafile/python3-lhafile.info
new file mode 100644
index 0000000000..8d25d49e27
--- /dev/null
+++ b/python/python3-lhafile/python3-lhafile.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-lhafile"
+VERSION="0.1.0fs4"
+HOMEPAGE="http://fengestad.no/python-lhafile/"
+DOWNLOAD="http://fengestad.no/python-lhafile/python-lhafile-0.1.0fs4.tar.gz"
+MD5SUM="cedac40d5363bf49b51528522bf05c60"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Marcel Saegebarth"
+EMAIL="marc@mos6581.de"
diff --git a/python/python3-lhafile/slack-desc b/python/python3-lhafile/slack-desc
new file mode 100644
index 0000000000..c75ffc27ff
--- /dev/null
+++ b/python/python3-lhafile/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-lhafile: python3-lhafile (Python LHA archive extension)
+python3-lhafile:
+python3-lhafile: This project is an updated version of the project found
+python3-lhafile: at http://trac.neotitans.net/wiki/lhafile.
+python3-lhafile: It is primarily used as a component in FS-UAE Launcher to index and
+python3-lhafile: extract files from .lha archives. The project consists of a Python
+python3-lhafile: package (lhafile) and a C extension for Python (lzhlib).
+python3-lhafile:
+python3-lhafile: Homepage: http://fengestad.no/python-lhafile/
+python3-lhafile:
+python3-lhafile: