summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Nikos Giotis2015-08-23 10:07:36 +0200
committer Willy Sudiarto Raharjo2015-08-23 10:07:36 +0200
commitab945f835e570f3ba6a36f5814277f6a8d03926f (patch)
treeb98ae9f6603be79d45e7337325e2e801d6516376 /python
parentb485090cdea9a4037da74c717054cf78d503fe70 (diff)
downloadslackbuilds-ab945f835e570f3ba6a36f5814277f6a8d03926f.tar.gz
python/python3-pyparted: Added (Python 3 bindings for libparted).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-pyparted/README7
-rw-r--r--python/python3-pyparted/python3-pyparted.SlackBuild90
-rw-r--r--python/python3-pyparted/python3-pyparted.info10
-rw-r--r--python/python3-pyparted/slack-desc26
4 files changed, 133 insertions, 0 deletions
diff --git a/python/python3-pyparted/README b/python/python3-pyparted/README
new file mode 100644
index 0000000000..ae232c1676
--- /dev/null
+++ b/python/python3-pyparted/README
@@ -0,0 +1,7 @@
+pyparted
+Python bindings for libparted
+-----------------------------
+
+pyparted is a set of native Python bindings for libparted. libparted is the
+library portion of the GNU parted project. With pyparted, you can write
+applications that interact with disk partition tables and filesystems.
diff --git a/python/python3-pyparted/python3-pyparted.SlackBuild b/python/python3-pyparted/python3-pyparted.SlackBuild
new file mode 100644
index 0000000000..283a7f24b0
--- /dev/null
+++ b/python/python3-pyparted/python3-pyparted.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for python3-pyparted
+
+# Copyright 2015 Nikos Giotis <nikos.giotis@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python3-pyparted
+SRCNAM=pyparted
+VERSION=${VERSION:-3.10.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+if [ -r $CWD/v$VERSION.tar.gz ]; then
+ mv $CWD/v$VERSION.tar.gz $CWD/$SRCNAM-$VERSION.tar.gz
+fi
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS BUGS COPYING HACKING NEWS README RELEASE TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-pyparted/python3-pyparted.info b/python/python3-pyparted/python3-pyparted.info
new file mode 100644
index 0000000000..6f466a8e70
--- /dev/null
+++ b/python/python3-pyparted/python3-pyparted.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-pyparted"
+VERSION="3.10.5"
+HOMEPAGE="https://github.com/rhinstaller/pyparted"
+DOWNLOAD="https://github.com/rhinstaller/pyparted/archive/v3.10.5.tar.gz"
+MD5SUM="b303caf8e907a2541e71aa492494b5e5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Nikos Giotis"
+EMAIL="nikos.giotis@gmail.com"
diff --git a/python/python3-pyparted/slack-desc b/python/python3-pyparted/slack-desc
new file mode 100644
index 0000000000..c3ce00770f
--- /dev/null
+++ b/python/python3-pyparted/slack-desc
@@ -0,0 +1,26 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-pyparted: python3-pyparted (Python 3 bindings for libparted)
+python3-pyparted:
+python3-pyparted: pyparted is a set of native Python 3 bindings for libparted.
+python3-pyparted: libparted is the library portion of the GNU parted project.
+python3-pyparted: With pyparted, you can write applications that interact with disk
+python3-pyparted: partition tables and filesystems.
+python3-pyparted:
+python3-pyparted: Homepage: https://github.com/rhinstaller/pyparted
+python3-pyparted:
+python3-pyparted:
+python3-pyparted: