summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Ken Roberts2014-04-11 18:06:12 +0200
committer Willy Sudiarto Raharjo2014-04-11 18:17:13 +0200
commit4ab63be0abff50624eaef4b9a2ce72bc4df15730 (patch)
treeab80f833828370bd80ac5ac282e50e8d1b4e1a56 /python
parentbb1a852378eaa35475e8945f51a96f14f0e9c853 (diff)
downloadslackbuilds-4ab63be0abff50624eaef4b9a2ce72bc4df15730.tar.gz
python/polib: Added (pot, po, and mo manipulation library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/polib/README11
-rw-r--r--python/polib/polib.SlackBuild95
-rw-r--r--python/polib/polib.info10
-rw-r--r--python/polib/slack-desc19
4 files changed, 135 insertions, 0 deletions
diff --git a/python/polib/README b/python/polib/README
new file mode 100644
index 0000000000..69123d0da4
--- /dev/null
+++ b/python/polib/README
@@ -0,0 +1,11 @@
+polib allows you to manipulate, create, modify gettext files
+(pot, po and mo files).
+
+You can load existing files, iterate through it's entries, add,
+modify entries, comments or metadata, etc... or create new po files
+from scratch.
+
+polib supports out of the box any version of python ranging from
+2.4 to latest 3.X version.
+
+Optional dependency: Sphinx
diff --git a/python/polib/polib.SlackBuild b/python/polib/polib.SlackBuild
new file mode 100644
index 0000000000..6ab776004a
--- /dev/null
+++ b/python/polib/polib.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/sh
+#
+# Copyright 2014, Ken Roberts, California, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=polib
+VERSION=${VERSION:-1.0.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+# Don't fail if sphinx not installed
+if [ -x /usr/bin/sphinx-build ] ; then
+ ( cd $TMP/$PRGNAM-$VERSION/doc
+ make html
+ make pickle
+ make json
+ make htmlhelp
+ make qthelp
+ PAPER=letter make latex
+ mv ./_build/* $PKG/usr/doc/$PRGNAM-$VERSION/
+ )
+else
+ echo "Sphinx documenting program not found"
+ echo "Skipping document building"
+fi
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/polib/polib.info b/python/polib/polib.info
new file mode 100644
index 0000000000..e392e675d8
--- /dev/null
+++ b/python/polib/polib.info
@@ -0,0 +1,10 @@
+PRGNAM="polib"
+VERSION="1.0.4"
+HOMEPAGE="https://bitbucket.org/izi/polib/wiki/Home"
+DOWNLOAD="https://bitbucket.org/izi/polib/downloads/polib-1.0.4.tar.gz"
+MD5SUM="5ff0b5b39bde42a859f4bd4ddad2a229"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Ken Roberts"
+EMAIL="alisonken1@juno.com"
diff --git a/python/polib/slack-desc b/python/polib/slack-desc
new file mode 100644
index 0000000000..6fcc7833e3
--- /dev/null
+++ b/python/polib/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+polib: polib (pot, po, and mo file manipulation library)
+polib:
+polib: Allows you to load existing files, iterate through it's entries, add,
+polib: modify entries, comments or metadata, etc., or create new po files
+polib: from scratch.
+polib:
+polib: Homepage: https://bitbucket.org/izi/polib/wiki/Home
+polib:
+polib:
+polib:
+polib: