summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Markus Reichelt2013-12-26 21:32:04 +0100
committer Erik Hanson2014-01-07 18:13:05 +0100
commitfdac2cc32754174beae4e405441c3b2f344267f1 (patch)
tree5701d1ffd383f4cdf1570b8f177bf5ac8848137f /python
parentbe44aac8a86e9c7efa0e9b2771eeb4c81f24b1fd (diff)
downloadslackbuilds-fdac2cc32754174beae4e405441c3b2f344267f1.tar.gz
python/stem: Updated for version 1.1.1.
Added a doc building section Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/stem/README8
-rw-r--r--python/stem/stem.SlackBuild27
-rw-r--r--python/stem/stem.info6
3 files changed, 29 insertions, 12 deletions
diff --git a/python/stem/README b/python/stem/README
index 2cb67e53a7..3f5ce7d842 100644
--- a/python/stem/README
+++ b/python/stem/README
@@ -2,6 +2,8 @@ stem is a Python controller library for Tor
stem is compatible with python 2.6+ (including python 3)
-Having Tor installed is not required for building,
-but obviously it is for actually using this library.
-The tor installation does not have to be from SBo.
+Having Tor installed is not required for building.
+The Tor installation does not have to be from SBo.
+
+Sphinx is an optional dependency to create proper documentation.
+In order to do so, pass DOC=yes to the script.
diff --git a/python/stem/stem.SlackBuild b/python/stem/stem.SlackBuild
index cf667c9c29..20fa1ffda3 100644
--- a/python/stem/stem.SlackBuild
+++ b/python/stem/stem.SlackBuild
@@ -24,7 +24,7 @@
# Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
PRGNAM=stem
-VERSION=${VERSION:-1.0.1}
+VERSION=${VERSION:-1.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -65,20 +65,35 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+cd $TMP/$PRGNAM-$VERSION
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION $PKG/usr/man1
cp -a docs/ LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+if [ "$DOC" = "yes" ]; then
+ cd $TMP/$PRGNAM-$VERSION/docs
+ make html
+ make man
+ cp -a _build/html $PKG/usr/doc/$PRGNAM-$VERSION
+ rm $PKG/usr/doc/$PRGNAM-$VERSION/html/{.buildinfo,objects.inv}
+ cp -a _build/man $PKG/usr/man1
+ find $PKG/usr/man1 -type f -exec gzip -9 {} \;
+ for i in $( find $PKG/usr/man1 -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+ rm -rf $PKG/usr/doc/$PRGNAM-$VERSION/docs/*
+ rmdir $PKG/usr/doc/$PRGNAM-$VERSION/docs
+fi;
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/python/stem/stem.info b/python/stem/stem.info
index b1014548c7..5d6a6f4a71 100644
--- a/python/stem/stem.info
+++ b/python/stem/stem.info
@@ -1,8 +1,8 @@
PRGNAM="stem"
-VERSION="1.0.1"
+VERSION="1.1.1"
HOMEPAGE="https://stem.torproject.org/"
-DOWNLOAD="http://www.atagar.com/transfer/stem/stem-1.0.1.tar.bz2"
-MD5SUM="f21cac5ab6c8aca975f4bc1db73ff5e5"
+DOWNLOAD="https://pypi.python.org/packages/source/s/stem/stem-1.1.1.tar.bz2"
+MD5SUM="e375b0e257ea7db9ae36c2324f4a8abf"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""