summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Larry Hajali2013-06-02 08:00:30 +0200
committer Robby Workman2013-06-04 07:11:22 +0200
commitddc5e64759fe86dec9bc365081efe343ff12906c (patch)
tree628d6aab8d083da159fcd486b61c4cac9a8ba294 /python
parent047d4962cf24335e4e4f66008d0633385974cde3 (diff)
downloadslackbuilds-ddc5e64759fe86dec9bc365081efe343ff12906c.tar.gz
python/pyinotify: Updated for version 0.9.4.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pyinotify/README2
-rw-r--r--python/pyinotify/pyinotify.SlackBuild15
-rw-r--r--python/pyinotify/pyinotify.info8
3 files changed, 17 insertions, 8 deletions
diff --git a/python/pyinotify/README b/python/pyinotify/README
index 40c4baeba2..f67a325c78 100644
--- a/python/pyinotify/README
+++ b/python/pyinotify/README
@@ -2,3 +2,5 @@ Pyinotify is a Python module for monitoring filesystems changes.
Pyinotify relies on a Linux Kernel feature (merged in kernel 2.6.13)
called inotify. inotify is an event-driven notifier, its notifications
are exported from kernel space to user space through three system calls.
+
+distribute and python3 are optional deps that will be used if present.
diff --git a/python/pyinotify/pyinotify.SlackBuild b/python/pyinotify/pyinotify.SlackBuild
index 342ac21cb5..07212a8d06 100644
--- a/python/pyinotify/pyinotify.SlackBuild
+++ b/python/pyinotify/pyinotify.SlackBuild
@@ -5,7 +5,7 @@
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
PRGNAM=pyinotify
-VERSION=${VERSION:-0.9.0}
+VERSION=${VERSION:-0.9.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -27,9 +27,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM
+rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM
+cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -37,13 +37,20 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Compile the C extension.
+sed -i '/^compile_ext_mod/s|=.*|= True|' setup.py
+
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ACKS ChangeLog_old COPYING NEWS_old $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ACKS COPYING PKG-INFO README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/pyinotify/pyinotify.info b/python/pyinotify/pyinotify.info
index 2a634ac85f..588c9cbf42 100644
--- a/python/pyinotify/pyinotify.info
+++ b/python/pyinotify/pyinotify.info
@@ -1,8 +1,8 @@
PRGNAM="pyinotify"
-VERSION="0.9.0"
-HOMEPAGE="http://trac.dbzteam.org/pyinotify"
-DOWNLOAD="http://seb.dbzteam.org/pub/pyinotify/releases/pyinotify-0.9.0.tar.gz"
-MD5SUM="9822b3cfe1494e1a9e8bce70b1214db7"
+VERSION="0.9.4"
+HOMEPAGE="https://github.com/seb-m/pyinotify"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pyinotify/pyinotify-0.9.4.tar.gz"
+MD5SUM="701c91854d241514ede7ffe72086566d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""