summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Larry Hajali2011-12-20 06:17:41 +0100
committer Robby Workman2011-12-20 06:17:41 +0100
commitd4e28c811126976c987efcdeb5f6d0647f613fd5 (patch)
tree72f501f20895219d7a45180d82bbe012bb07ad06 /python
parent5307c9ad60c78b8e90f561e0bed8f2c94444ca2d (diff)
downloadslackbuilds-d4e28c811126976c987efcdeb5f6d0647f613fd5.tar.gz
python/rope: Added (python refactoring library)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/rope/README3
-rw-r--r--python/rope/rope.SlackBuild69
-rw-r--r--python/rope/rope.info10
-rw-r--r--python/rope/slack-desc19
4 files changed, 101 insertions, 0 deletions
diff --git a/python/rope/README b/python/rope/README
new file mode 100644
index 0000000000..9fe70b4085
--- /dev/null
+++ b/python/rope/README
@@ -0,0 +1,3 @@
+Rope is a python refactoring library.
+
+Rope can optionally use pysetuptools/distribute during build time.
diff --git a/python/rope/rope.SlackBuild b/python/rope/rope.SlackBuild
new file mode 100644
index 0000000000..3d3f61138f
--- /dev/null
+++ b/python/rope/rope.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+# Slackware build script for rope
+
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=rope
+VERSION=${VERSION:-0.9.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING PKG-INFO README.txt docs/* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/rope/rope.info b/python/rope/rope.info
new file mode 100644
index 0000000000..172c3a120d
--- /dev/null
+++ b/python/rope/rope.info
@@ -0,0 +1,10 @@
+PRGNAM="rope"
+VERSION="0.9.3"
+HOMEPAGE="http://rope.sourceforge.net/"
+DOWNLOAD="http://pypi.python.org/packages/source/r/rope/rope-0.9.3.tar.gz"
+MD5SUM="b04971636816d62157cf26e2ec5c1a37"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="rworkman"
diff --git a/python/rope/slack-desc b/python/rope/slack-desc
new file mode 100644
index 0000000000..03851a7cf5
--- /dev/null
+++ b/python/rope/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+rope: rope (python refactoring library)
+rope:
+rope: Rope is a python refactoring library.
+rope:
+rope: Homepage: http://rope.sourceforge.net/
+rope:
+rope:
+rope:
+rope:
+rope:
+rope: