summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-01-06 19:01:49 +0100
committer Erik Hanson2014-01-07 18:13:07 +0100
commitb87924e1ad50c207a355f82988a33992850bbe09 (patch)
tree396c42aff8c88299f7d54fd2c9b63c5e2d397bec /python
parentec490fb9a05583709c558100a89d56b506bc0c82 (diff)
downloadslackbuilds-b87924e1ad50c207a355f82988a33992850bbe09.tar.gz
python/sql: Added (DB API 2.0 for humans).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/sql/README9
-rw-r--r--python/sql/slack-desc19
-rw-r--r--python/sql/sql.SlackBuild88
-rw-r--r--python/sql/sql.info10
4 files changed, 126 insertions, 0 deletions
diff --git a/python/sql/README b/python/sql/README
new file mode 100644
index 0000000000..866e7ef569
--- /dev/null
+++ b/python/sql/README
@@ -0,0 +1,9 @@
+DB API 2.0 works. ORMs are convenient but sometimes overkill.
+sql is a lightweight wrapper sitting on top of any DB API 2.0
+connection offering a postgres like interface which makes working
+with SQL results bliss.
+
+If you want to build this for use with Python 3.x (needs the
+optional dependency python3) pass the script PYTHON3=yes, like
+
+ PYTHON3=yes ./sql.SlackBuild
diff --git a/python/sql/slack-desc b/python/sql/slack-desc
new file mode 100644
index 0000000000..2141e1add0
--- /dev/null
+++ b/python/sql/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+sql: sql (python DB API 2.0 for humans)
+sql:
+sql: DB API 2.0 works. ORMs are convenient but sometimes overkill.
+sql: sql is a lightweight wrapper sitting on top of any DB API 2.0
+sql: connection offering a postgres like interface which makes working
+sql: with SQL results bliss.
+sql:
+sql: homeproject : http://github.com/3kwa/sql
+sql:
+sql:
+sql:
diff --git a/python/sql/sql.SlackBuild b/python/sql/sql.SlackBuild
new file mode 100644
index 0000000000..4ea9bf3d60
--- /dev/null
+++ b/python/sql/sql.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for sql
+
+# Copyright 2013 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=sql
+VERSION=${VERSION:-0.4.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+PYTHON=python
+[ "${PYTHON3:-no}" = "yes" ] && PYTHON=python3
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+$PYTHON setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst PKG-INFO LICENCE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/sql/sql.info b/python/sql/sql.info
new file mode 100644
index 0000000000..9697a0a8b8
--- /dev/null
+++ b/python/sql/sql.info
@@ -0,0 +1,10 @@
+PRGNAM="sql"
+VERSION="0.4.0"
+HOMEPAGE="http://github.com/3kwa/sql"
+DOWNLOAD="https://pypi.python.org/packages/source/s/sql/sql-0.4.0.tar.gz"
+MD5SUM="04b89730b9c5432dddc83e6f33ddb326"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"