summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author klaatu2013-06-04 23:15:42 +0200
committer Robby Workman2013-06-05 10:17:44 +0200
commita72cc2c168bf1a76b4ce9603b696a0810bfee2de (patch)
treec7ecdbcdb38736cd34d9a4b51b6a680e94525b42 /python
parentbab534f26cda6882d85970582a6ffc0cb3700e43 (diff)
downloadslackbuilds-a72cc2c168bf1a76b4ce9603b696a0810bfee2de.tar.gz
python/lockfile: Added (API for locking files)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/lockfile/README8
-rw-r--r--python/lockfile/lockfile.SlackBuild75
-rw-r--r--python/lockfile/lockfile.info10
-rw-r--r--python/lockfile/slack-desc19
4 files changed, 112 insertions, 0 deletions
diff --git a/python/lockfile/README b/python/lockfile/README
new file mode 100644
index 0000000000..fbfc355f8c
--- /dev/null
+++ b/python/lockfile/README
@@ -0,0 +1,8 @@
+The lockfile package exports a LockFile class which provides a simple
+API for locking files.
+
+Unlike the Windows msvcrt.locking function, the fcntl.lockf and flock
+functions, and the deprecated posixfile module, the API is identical
+across both Unix (including Linux and Mac) and Windows platforms.
+
+This package is version 0.8 due to some API breakage in 0.9+
diff --git a/python/lockfile/lockfile.SlackBuild b/python/lockfile/lockfile.SlackBuild
new file mode 100644
index 0000000000..8974c1c5d5
--- /dev/null
+++ b/python/lockfile/lockfile.SlackBuild
@@ -0,0 +1,75 @@
+#!/bin/sh
+
+# Slackware build script for lockfile
+
+# Copyright 2013 klaatu at member.fsf.org
+#
+# GNU All-Permissive License
+# Copying and distribution of this file, with or without modification,
+# are permitted in any medium without royalty provided the copyright
+# notice and this notice are preserved. This file is offered as-is,
+# without any warranty.
+
+PRGNAM=lockfile
+VERSION=${VERSION:-0.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ PKG-INFO MANIFEST README RELEASE-NOTES \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/lockfile/lockfile.info b/python/lockfile/lockfile.info
new file mode 100644
index 0000000000..14f8d38b36
--- /dev/null
+++ b/python/lockfile/lockfile.info
@@ -0,0 +1,10 @@
+PRGNAM="lockfile"
+VERSION="0.8"
+HOMEPAGE="http://code.google.com/p/pylockfile/"
+DOWNLOAD="http://pylockfile.googlecode.com/files/lockfile-0.8.tar.gz"
+MD5SUM="2d515e19eb6f69d6ed711cbbafdec7ef"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="distribute"
+MAINTAINER="klaatu"
+EMAIL="klaatu@member.nospam.fsf.org"
diff --git a/python/lockfile/slack-desc b/python/lockfile/slack-desc
new file mode 100644
index 0000000000..7c5e1f5a74
--- /dev/null
+++ b/python/lockfile/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+lockfile: lockfile (API for locking files)
+lockfile:
+lockfile: The lockfile package exports a LockFile class which provides a
+lockfile: simple API for locking files.
+lockfile:
+lockfile: http://code.google.com/p/pylockfile/
+lockfile:
+lockfile:
+lockfile:
+lockfile:
+lockfile: