summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2014-02-02 00:55:45 +0100
committer Robby Workman2014-02-02 09:09:50 +0100
commit60a71216fb889c7d523203a1386e2a298a0c4333 (patch)
treedb501d136c1249529ff05da6fb4e251a39846e2c /python
parentf8dd5ba15a6c5185a406611121305e8f718a21f6 (diff)
downloadslackbuilds-60a71216fb889c7d523203a1386e2a298a0c4333.tar.gz
gis/geopy: Moved from Python category.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/geopy/README9
-rw-r--r--python/geopy/geopy.SlackBuild70
-rw-r--r--python/geopy/geopy.info10
-rw-r--r--python/geopy/slack-desc19
4 files changed, 0 insertions, 108 deletions
diff --git a/python/geopy/README b/python/geopy/README
deleted file mode 100644
index a259e8cd30..0000000000
--- a/python/geopy/README
+++ /dev/null
@@ -1,9 +0,0 @@
-geopy makes it easy for developers to locate the coordinates of addresses,
-cities, countries, and landmarks across the globe using third-party
-geocoders and other data sources, such as wikis.
-
-geopy currently includes support for six geocoders: Google Maps, Yahoo!
-Maps, Windows Local Live (Virtual Earth), geocoder.us, GeoNames, MediaWiki
-pages (with the GIS extension), and Semantic MediaWiki pages.
-
-See http://code.google.com/p/geopy/wiki/GettingStarted for more details.
diff --git a/python/geopy/geopy.SlackBuild b/python/geopy/geopy.SlackBuild
deleted file mode 100644
index 798e5dcef4..0000000000
--- a/python/geopy/geopy.SlackBuild
+++ /dev/null
@@ -1,70 +0,0 @@
-#!/bin/sh
-
-# SlackBuild for geopy python library
-
-# Written by Dominik Drobek <dominik.drobek (at) o2.pl>
-# Formerly maintained by Francisco Sokol <chico.sokol@gmail.com>
-# Currently maintained by Benjamin Trigona-Harany
-
-PRGNAM=geopy
-VERSION=${VERSION:-0.97}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-release-$VERSION
-if [ -e $CWD/release-$VERSION.tar.gz ]; then
- tar xvf $CWD/release-$VERSION.tar.gz
-else
- tar xvf $CWD/$PRGNAM-release-$VERSION.tar.gz
-fi
-cd $PRGNAM-release-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.markdown RELEASES $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/geopy/geopy.info b/python/geopy/geopy.info
deleted file mode 100644
index c73818251f..0000000000
--- a/python/geopy/geopy.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="geopy"
-VERSION="0.97"
-HOMEPAGE="https://github.com/geopy/geopy"
-DOWNLOAD="https://github.com/geopy/geopy/archive/release-0.97.tar.gz"
-MD5SUM="2e55f5e548b2301d01bb1ab1986c8674"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pysetuptools"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/geopy/slack-desc b/python/geopy/slack-desc
deleted file mode 100644
index 6ef7e0038c..0000000000
--- a/python/geopy/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-geopy: geopy (A Geocoding Toolbox for Python)
-geopy:
-geopy: geopy makes it easy for developers to locate the coordinates of
-geopy: addresses, cities, countries, and landmarks across the globe using
-geopy: third-party geocoders and other data sources, such as wikis.
-geopy:
-geopy: geopy currently includes support for six geocoders: Google Maps,
-geopy: Yahoo! Maps, Windows Local Live (Virtual Earth), geocoder.us,
-geopy: GeoNames, MediaWiki pages (with the GIS extension), and Semantic
-geopy: MediaWiki pages.
-geopy: