summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Mohamed LYAHYAOUI2013-12-17 16:24:26 +0100
committer Erik Hanson2013-12-17 18:00:46 +0100
commit5648005a0ec5f290c60cf8b03c1eeb91a7678187 (patch)
tree096a93e26af9ec99821b38c6680b43dd948ec310 /python
parentfc734dd5a347d39b30372826add9bc9d9d561542 (diff)
downloadslackbuilds-5648005a0ec5f290c60cf8b03c1eeb91a7678187.tar.gz
python/vatnumber: Added (Python module to validate VAT numbers).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/vatnumber/README3
-rw-r--r--python/vatnumber/slack-desc20
-rw-r--r--python/vatnumber/vatnumber.SlackBuild87
-rw-r--r--python/vatnumber/vatnumber.info10
4 files changed, 120 insertions, 0 deletions
diff --git a/python/vatnumber/README b/python/vatnumber/README
new file mode 100644
index 0000000000..286101121b
--- /dev/null
+++ b/python/vatnumber/README
@@ -0,0 +1,3 @@
+Python module to validate VAT numbers
+
+Optional dependency: suds (https://fedorahosted.org/suds/)
diff --git a/python/vatnumber/slack-desc b/python/vatnumber/slack-desc
new file mode 100644
index 0000000000..f238ec4017
--- /dev/null
+++ b/python/vatnumber/slack-desc
@@ -0,0 +1,20 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+vatnumber: vatnumber (Python module to validate VAT numbers)
+vatnumber:
+vatnumber: Python module to validate VAT numbers.
+vatnumber:
+vatnumber:
+vatnumber:
+vatnumber:
+vatnumber:
+vatnumber: Homepage: https://code.google.com/p/vatnumber/
+vatnumber:
+vatnumber:
+
diff --git a/python/vatnumber/vatnumber.SlackBuild b/python/vatnumber/vatnumber.SlackBuild
new file mode 100644
index 0000000000..aeb3a5601f
--- /dev/null
+++ b/python/vatnumber/vatnumber.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for vatnumber
+
+# Copyright 2013 Mohamed LYAHYAOUI <mlyahyaoui@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=vatnumber
+VERSION=${VERSION:-1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="LICENSE README"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py build || exit 1
+
+python setup.py install --root $PKG || exit 1
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/vatnumber/vatnumber.info b/python/vatnumber/vatnumber.info
new file mode 100644
index 0000000000..eec78da636
--- /dev/null
+++ b/python/vatnumber/vatnumber.info
@@ -0,0 +1,10 @@
+PRGNAM="vatnumber"
+VERSION="1.1"
+HOMEPAGE="https://code.google.com/p/vatnumber"
+DOWNLOAD="https://vatnumber.googlecode.com/files/vatnumber-1.1.tar.gz"
+MD5SUM="7b57a0e7e3debbbfdf8c4d8472e8e947"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Mohamed LYAHYAOUI"
+EMAIL="mlyahyaoui@gmail.com"