summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author LukenShiro2011-11-01 11:40:58 +0100
committer Niels Horn2011-11-01 11:40:58 +0100
commit5331682a26ab2104f07e1dcc45a6857ac9773b01 (patch)
tree95c2d56b83f33f12b7bcd9ecf3f59320e6df4153 /python
parente885adb06d5713b43bb51a872f644f44de2ca624 (diff)
downloadslackbuilds-5331682a26ab2104f07e1dcc45a6857ac9773b01.tar.gz
python/pyflakes: Updated for version 0.5.0 (+new category)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pyflakes/README17
-rw-r--r--python/pyflakes/pyflakes.SlackBuild71
-rw-r--r--python/pyflakes/pyflakes.info10
-rw-r--r--python/pyflakes/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/python/pyflakes/README b/python/pyflakes/README
new file mode 100644
index 0000000000..ffc04d348b
--- /dev/null
+++ b/python/pyflakes/README
@@ -0,0 +1,17 @@
+PyFlakes a Lint-like tool for Python, like PyChecker. It is focused on
+identifying common errors quickly without executing Python code.
+
+Its primary advantage over PyChecker is that it is fast. You don't have
+to sit around for minutes waiting for the checker to run; it runs on most
+large projects in only a few seconds.
+
+The two primary categories of defects reported by PyFlakes are:
+* Names which are used but not defined or used before they are defined
+* Names which are redefined without having been used
+
+These can each take many forms. For example, PyFlakes will tell you when
+you have forgotten an import, mistyped a variable name, defined two
+functions with the same name, shadowed a variable from another scope,
+imported a module twice, or two different modules with the same name, and
+so on.
+
diff --git a/python/pyflakes/pyflakes.SlackBuild b/python/pyflakes/pyflakes.SlackBuild
new file mode 100644
index 0000000000..7c530c1ee7
--- /dev/null
+++ b/python/pyflakes/pyflakes.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Slackware build script for pyflakes
+
+# Copyright 2010-2011 LukenShiro <lukenshiro@ngi.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyflakes
+VERSION=${VERSION:-0.5.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCFILES="PKG-INFO"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py build
+python setup.py install --prefix=/usr/ --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pyflakes/pyflakes.info b/python/pyflakes/pyflakes.info
new file mode 100644
index 0000000000..797606a16b
--- /dev/null
+++ b/python/pyflakes/pyflakes.info
@@ -0,0 +1,10 @@
+PRGNAM="pyflakes"
+VERSION="0.5.0"
+HOMEPAGE="http://www.divmod.org/trac/wiki/DivmodPyflakes"
+DOWNLOAD="http://pypi.python.org/packages/source/p/pyflakes/pyflakes-0.5.0.tar.gz"
+MD5SUM="568dab27c42e5822787aa8a603898672"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="LukenShiro"
+EMAIL="lukenshiro@ngi.it"
+APPROVED="Niels Horn"
diff --git a/python/pyflakes/slack-desc b/python/pyflakes/slack-desc
new file mode 100644
index 0000000000..747587f819
--- /dev/null
+++ b/python/pyflakes/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pyflakes: pyflakes (passive checker of Python programs)
+pyflakes:
+pyflakes: Pyflakes is a program to analyze Python programs and detect various
+pyflakes: errors. It works by parsing the source file, not importing it, so it
+pyflakes: is safe to use on modules with side effects. It's also much faster
+pyflakes: passive checker of Python programs.
+pyflakes:
+pyflakes:
+pyflakes:
+pyflakes: Homepage: http://www.divmod.org/trac/wiki/DivmodPyflakes
+pyflakes: