summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Bernski Comadizo2013-03-12 02:13:24 +0100
committer dsomero2013-03-22 12:16:44 +0100
commit38db011e7f8c59e558c18f8b65a26ed0a7530a09 (patch)
treea9902cb14c740f1bd04f7df484a1ddfccfda839e /python
parenta38abcad761d522c3abcac5a9e5435bda4f82adb (diff)
downloadslackbuilds-38db011e7f8c59e558c18f8b65a26ed0a7530a09.tar.gz
python/RBTools: Added (utility scripts for use with Review Board)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/RBTools/RBTools.SlackBuild51
-rw-r--r--python/RBTools/RBTools.info10
-rw-r--r--python/RBTools/README11
-rw-r--r--python/RBTools/slack-desc19
4 files changed, 91 insertions, 0 deletions
diff --git a/python/RBTools/RBTools.SlackBuild b/python/RBTools/RBTools.SlackBuild
new file mode 100644
index 0000000000..b7b110f403
--- /dev/null
+++ b/python/RBTools/RBTools.SlackBuild
@@ -0,0 +1,51 @@
+#!/bin/sh
+
+# Slackware build script for RBTools
+# 2013-03-07 Bernski Comadizo <bcomadizo@gmail.com> Cebu
+
+PRGNAM=RBTools
+VERSION=${VERSION:-0.4.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ NEWS PKG-INFO COPYING INSTALL README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/RBTools/RBTools.info b/python/RBTools/RBTools.info
new file mode 100644
index 0000000000..8bf8065d42
--- /dev/null
+++ b/python/RBTools/RBTools.info
@@ -0,0 +1,10 @@
+PRGNAM="RBTools"
+VERSION="0.4.3"
+HOMEPAGE="http://www.reviewboard.org"
+DOWNLOAD="http://downloads.reviewboard.org/releases/RBTools/0.4/RBTools-0.4.3.tar.gz"
+MD5SUM="fc76cbe3a9f023a012966577bdd300d6"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Bernski Comadizo"
+EMAIL="bcomadizo@gmail.com"
diff --git a/python/RBTools/README b/python/RBTools/README
new file mode 100644
index 0000000000..8d08687210
--- /dev/null
+++ b/python/RBTools/README
@@ -0,0 +1,11 @@
+RBTools is a collection of console utility scripts for use with Review Board.
+
+This consists of the following officially supported tools:
+
+ * post-review - Create and update review requests based on changes in
+ a local tree.
+
+There are also some user-contributed scripts and application plugins in the
+contrib directory. See the associated README files for more information.
+
+This release works with Review Board 1.7.3.
diff --git a/python/RBTools/slack-desc b/python/RBTools/slack-desc
new file mode 100644
index 0000000000..3d62b5cdb7
--- /dev/null
+++ b/python/RBTools/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+RBTools: RBTools (collection of utility scripts for use with Review Board)
+RBTools:
+RBTools: This consists of the following officially supported tools:
+RBTools: * post-review - Create and update review requests based on
+RBTools: changes in a local tree.
+RBTools:
+RBTools: There are also some user-contributed scripts and application plugins
+RBTools: in the contrib directory. See the associated README files for more
+RBTools: information.
+RBTools:
+RBTools: This release works with Review Board 1.7.3.