summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-02-03 13:02:50 +0100
committer Erik Hanson2014-02-08 18:10:27 +0100
commit3795956fae85bb21d1ee25fb0a95cf8b276667a0 (patch)
treefcfd4404bc2e482857beb90645c5921d8774c967 /python
parent6f34dbca4376924913ba6d489ae5804bfc6c05f7 (diff)
downloadslackbuilds-3795956fae85bb21d1ee25fb0a95cf8b276667a0.tar.gz
python/selenium: Added (Python bindings for Selenium).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/selenium/README9
-rw-r--r--python/selenium/selenium.SlackBuild85
-rw-r--r--python/selenium/selenium.info10
-rw-r--r--python/selenium/slack-desc19
4 files changed, 123 insertions, 0 deletions
diff --git a/python/selenium/README b/python/selenium/README
new file mode 100644
index 0000000000..d7d3e713df
--- /dev/null
+++ b/python/selenium/README
@@ -0,0 +1,9 @@
+Selenium automates browsers.
+That's it! What you do with that power is entirely up to you.
+Primarily, it is for automating web applications for testing purposes,
+but is certainly not limited to just that. Boring web-based administration
+tasks can (and should!) also be automated as well.
+Selenium has the support of some of the largest browser vendors who have
+taken (or are taking) steps to make Selenium a native part of their browser.
+It is also the core technology in countless other browser automation tools,
+APIs and frameworks.
diff --git a/python/selenium/selenium.SlackBuild b/python/selenium/selenium.SlackBuild
new file mode 100644
index 0000000000..2a92b668af
--- /dev/null
+++ b/python/selenium/selenium.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for selenium
+
+# Copyright 2014 Dimitris Zlatanidis, Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=selenium
+VERSION=${VERSION:-2.39.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/selenium/selenium.info b/python/selenium/selenium.info
new file mode 100644
index 0000000000..cfcf022a8b
--- /dev/null
+++ b/python/selenium/selenium.info
@@ -0,0 +1,10 @@
+PRGNAM="selenium"
+VERSION="2.39"
+HOMEPAGE="http://www.seleniumhq.org"
+DOWNLOAD="https://pypi.python.org/packages/source/s/selenium/selenium-2.39.0.tar.gz"
+MD5SUM="3f7aaad3eb52a218854bf0196c9daeda"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/selenium/slack-desc b/python/selenium/slack-desc
new file mode 100644
index 0000000000..17af70b037
--- /dev/null
+++ b/python/selenium/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+selenium: selenium (Python bindings for Selenium)
+selenium:
+selenium: Python language bindings for Selenium WebDriver.
+selenium: The selenium package is used to automate web browser interaction
+selenium: from Python.
+selenium:
+selenium: homepage: http://seleniumhq.org
+selenium:
+selenium:
+selenium:
+selenium: