summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author John Tyree2011-12-21 12:31:24 +0100
committer Robby Workman2011-12-22 07:03:04 +0100
commit1ae8438259a629392bcc9bc76d6ab49f6b4b4313 (patch)
treed0ffff9b048a64928900269ccba960c36c3094a6 /python
parent216fa12d3b0af16f5e8925c8304d3b48a3b0eedb (diff)
downloadslackbuilds-1ae8438259a629392bcc9bc76d6ab49f6b4b4313.tar.gz
python/python-simpy: Added (OO Discrete Event Simulation in Python)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-simpy/README17
-rw-r--r--python/python-simpy/python-simpy.SlackBuild75
-rw-r--r--python/python-simpy/python-simpy.info10
-rw-r--r--python/python-simpy/slack-desc19
4 files changed, 121 insertions, 0 deletions
diff --git a/python/python-simpy/README b/python/python-simpy/README
new file mode 100644
index 0000000000..6cafad6caf
--- /dev/null
+++ b/python/python-simpy/README
@@ -0,0 +1,17 @@
+SimPy
+=====
+
+To build documentation, pass DOCS=yes to the slackbuild. Requires Sphinx.
+
+SimPy is a process-based discrete-event simulation language based on standard
+Python and released under the GNU LGPL.
+
+It provides the modeller with components of a simulation model. These include
+processes for active components like customers, messages and vehicles as well
+as resources for passive components that form limited capacity congestion
+points (like servers, checkout counters and tunnels). It also provides monitor
+variables to aid in gathering statistics. SimPy comes with extensive plotting
+capabilities.
+
+The distribution contains in-depth documentation, tutorials, and a large number
+of simulation models.
diff --git a/python/python-simpy/python-simpy.SlackBuild b/python/python-simpy/python-simpy.SlackBuild
new file mode 100644
index 0000000000..9114ef0912
--- /dev/null
+++ b/python/python-simpy/python-simpy.SlackBuild
@@ -0,0 +1,75 @@
+#!/bin/sh
+
+# Slackware build script for SimPy
+
+# Written by John Tyree <johntyree+sbo@gmail.com>
+
+PRGNAM=python-simpy
+VERSION=${VERSION:-2.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+SRCNAM=SimPy
+DOCS=${DOCS:-"no"}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.bz2
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Strip binaries and libraries.
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+if [[ $DOCS == "yes" ]]; then
+ (cd ./docs; make html; cp -a html $PKG/usr/doc/$PRGNAM-$VERSION)
+fi
+cp -a \
+ AUTHORS.txt CHANGES.txt LICENSE.txt README.txt docs/examples \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-simpy/python-simpy.info b/python/python-simpy/python-simpy.info
new file mode 100644
index 0000000000..507bdf2b1a
--- /dev/null
+++ b/python/python-simpy/python-simpy.info
@@ -0,0 +1,10 @@
+PRGNAM="python-simpy"
+VERSION="2.2"
+HOMEPAGE="http://simpy.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/project/simpy/simpy/SimPy-2.2/SimPy-2.2.tar.bz2"
+MD5SUM="62f973cc3160d7b5865ab6537add1cd2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="John Tyree"
+EMAIL="johntyree+sbo@gmail.com"
+APPROVED="dsomero"
diff --git a/python/python-simpy/slack-desc b/python/python-simpy/slack-desc
new file mode 100644
index 0000000000..f626d61d19
--- /dev/null
+++ b/python/python-simpy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python-simpy: python-simpy (Object Oriented Discrete Event Simulation in Python)
+python-simpy:
+python-simpy: SimPy (= Simulation in Python) is an object-oriented, process-based
+python-simpy: discrete-event simulation language based on standard Python. It
+python-simpy: provides the modeller with components of a simulation model including
+python-simpy: processes, for active components like customers, messages, and
+python-simpy: vehicles, and resources, for passive components that form limited
+python-simpy: capacity congestion points like servers, checkout counters, and
+python-simpy: tunnels.
+python-simpy:
+python-simpy: http://simpy.sourceforge.net