summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-01-06 22:25:08 +0100
committer Erik Hanson2014-01-07 18:13:07 +0100
commit08b3ed87ae3f4d48bba025bf3f3103f64cdc19c9 (patch)
tree9a9155ba884cb50906bcd731ceb2144d4f22898b /python
parente8839eb2a3810236885e1e40e8e383081725485b (diff)
downloadslackbuilds-08b3ed87ae3f4d48bba025bf3f3103f64cdc19c9.tar.gz
python/threadpool: Added (object-oriented thread pool framework).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/threadpool/README13
-rw-r--r--python/threadpool/slack-desc19
-rw-r--r--python/threadpool/threadpool.SlackBuild85
-rw-r--r--python/threadpool/threadpool.info10
4 files changed, 127 insertions, 0 deletions
diff --git a/python/threadpool/README b/python/threadpool/README
new file mode 100644
index 0000000000..1460b6122f
--- /dev/null
+++ b/python/threadpool/README
@@ -0,0 +1,13 @@
+A thread pool is an object that maintains a pool of worker threads to
+perform time consuming operations in parallel. It assigns jobs to the
+threads by putting them in a work request queue, where they are picked
+up by the next available thread. This then performs the requested
+operation in the background and puts the results in another queue.
+
+The thread pool object can then collect the results from all threads
+from this queue as soon as they become available or after all threads
+have finished their work. It's then possible to define callbacks to
+handle each result as it comes in.
+
+NOTE: This module is regarded as an extended example, not as a
+finished product. Feel free to adapt it too your needs.
diff --git a/python/threadpool/slack-desc b/python/threadpool/slack-desc
new file mode 100644
index 0000000000..2cc1bb77cd
--- /dev/null
+++ b/python/threadpool/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+threadpool: threadpool (Easy to use object-oriented thread pool framework)
+threadpool:
+threadpool: A thread pool is an object that maintains a pool of worker threads to
+threadpool: perform time consuming operations in parallel. It assigns jobs to the
+threadpool: threads by putting them in a work request queue, where they are picked
+threadpool: up by the next available thread. This then performs the requested
+threadpool: operation in the background and puts the results in another queue.
+threadpool:
+threadpool: homepage : http://chrisarndt.de/projects/threadpool/
+threadpool:
+threadpool:
diff --git a/python/threadpool/threadpool.SlackBuild b/python/threadpool/threadpool.SlackBuild
new file mode 100644
index 0000000000..7c342a28be
--- /dev/null
+++ b/python/threadpool/threadpool.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for threadpool
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=threadpool
+VERSION=${VERSION:-1.2.7}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.txt PKG-INFO CHANGELOG.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/threadpool/threadpool.info b/python/threadpool/threadpool.info
new file mode 100644
index 0000000000..7eeefe4815
--- /dev/null
+++ b/python/threadpool/threadpool.info
@@ -0,0 +1,10 @@
+PRGNAM="threadpool"
+VERSION="1.2.7"
+HOMEPAGE="http://chrisarndt.de/projects/threadpool/"
+DOWNLOAD="http://chrisarndt.de/projects/threadpool/download/threadpool-1.2.7.tar.bz2"
+MD5SUM="e1d5a4f73440ed701dfd0b3eb0d9c1ca"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="%README%"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"