summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author LukenShiro2013-11-11 16:13:05 +0100
committer Robby Workman2013-11-11 17:53:36 +0100
commit8a720b7565ebb622a1c75889a9266eb31f3f1305 (patch)
treedee479bddefca7ee732eac31503e5e512e5d34a5 /python
parent192892025092432f653c2c3c8f8ccbadc381d7ee (diff)
downloadslackbuilds-8a720b7565ebb622a1c75889a9266eb31f3f1305.tar.gz
various: fixes for new templates (find/fixperms)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/Pygments/Pygments.SlackBuild8
-rw-r--r--python/pydblite/pydblite.SlackBuild8
-rw-r--r--python/pyflakes/pyflakes.SlackBuild8
-rw-r--r--python/pyfltk/pyfltk.SlackBuild12
-rw-r--r--python/pytables/pytables.SlackBuild12
-rw-r--r--python/python-pmw/python-pmw.SlackBuild8
6 files changed, 29 insertions, 27 deletions
diff --git a/python/Pygments/Pygments.SlackBuild b/python/Pygments/Pygments.SlackBuild
index 90ddea2669..a082f9e38d 100644
--- a/python/Pygments/Pygments.SlackBuild
+++ b/python/Pygments/Pygments.SlackBuild
@@ -25,7 +25,7 @@
PRGNAM=Pygments
VERSION=${VERSION:-1.6}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -52,11 +52,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --prefix=/usr --root=$PKG
diff --git a/python/pydblite/pydblite.SlackBuild b/python/pydblite/pydblite.SlackBuild
index ea657bb32c..7686037e45 100644
--- a/python/pydblite/pydblite.SlackBuild
+++ b/python/pydblite/pydblite.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=pydblite
VERSION=${VERSION:-2.7}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -54,11 +54,11 @@ rm -rf $SRCNAM-$VERSION
unzip $CWD/$SRCNAM-$VERSION.zip
cd $SRCNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py build install --root=$PKG
diff --git a/python/pyflakes/pyflakes.SlackBuild b/python/pyflakes/pyflakes.SlackBuild
index c23a589577..07740d4781 100644
--- a/python/pyflakes/pyflakes.SlackBuild
+++ b/python/pyflakes/pyflakes.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=pyflakes
VERSION=${VERSION:-0.7.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -51,11 +51,11 @@ rm -rf $PRGNAM-$VERSION
tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --prefix=/usr/ --root=$PKG
diff --git a/python/pyfltk/pyfltk.SlackBuild b/python/pyfltk/pyfltk.SlackBuild
index b6223fec46..f1f5dbff74 100644
--- a/python/pyfltk/pyfltk.SlackBuild
+++ b/python/pyfltk/pyfltk.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyfltk
-# Copyright 2006-2010 LukenShiro <lukenshiro@ngi.it>
+# Copyright 2006-2010 LukenShiro, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,15 +24,13 @@
PRGNAM=pyfltk
VERSION=${VERSION:-1.1.5}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -59,7 +57,11 @@ rm -rf $SRC_PRGNAM-$VERSION
tar -xvf $CWD/$SRC_PRGNAM-$VERSION.tar.gz
cd $SRC_PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Copy documentation files
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/pytables/pytables.SlackBuild b/python/pytables/pytables.SlackBuild
index 9cae7b71d9..51c0e3d9d3 100644
--- a/python/pytables/pytables.SlackBuild
+++ b/python/pytables/pytables.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pytables
-# Copyright 2007-2013 LukenShiro <lukenshiro@ngi.it>
+# Copyright 2007-2013 LukenShiro, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=pytables
VERSION=${VERSION:-3.0.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -67,11 +67,11 @@ rm -rf $SRC_PRGNAM-$VERSION
tar xvf $CWD/$SRC_PRGNAM-$VERSION.tar.gz
cd $SRC_PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py build install --prefix=/usr --root=$PKG
diff --git a/python/python-pmw/python-pmw.SlackBuild b/python/python-pmw/python-pmw.SlackBuild
index dc132098c9..cb8ddcc317 100644
--- a/python/python-pmw/python-pmw.SlackBuild
+++ b/python/python-pmw/python-pmw.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=python-pmw
VERSION=${VERSION:-1.3.3a}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -66,11 +66,11 @@ cd $PRGNAM-$VERSION
tar xvf $CWD/${SRCPRGNAM}_${SRCVERSION}.tar.gz
cd $SRCPRGNAM/$SRCPRGNAM
chown -R root:root . || true
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Move documentation files
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION