summaryrefslogtreecommitdiffstats
path: root/python/timehash
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2016-04-18 06:34:11 +0200
committer Willy Sudiarto Raharjo2016-04-19 17:47:42 +0200
commit9f8413f510d1cb0167ba77f2c87901d54d3b6cf9 (patch)
tree21b1c1a3afbbd92d6a8433298cdada743ae9cbe7 /python/timehash
parent664d8f4fc2f73aec70ea2b76428979fe71a6f20c (diff)
downloadslackbuilds-9f8413f510d1cb0167ba77f2c87901d54d3b6cf9.tar.gz
gis/timehash: Added (module to decode/encode timehashes).
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'python/timehash')
-rw-r--r--python/timehash/README4
-rw-r--r--python/timehash/slack-desc19
-rw-r--r--python/timehash/timehash.SlackBuild85
-rw-r--r--python/timehash/timehash.info10
4 files changed, 118 insertions, 0 deletions
diff --git a/python/timehash/README b/python/timehash/README
new file mode 100644
index 0000000000..c16ff02fa8
--- /dev/null
+++ b/python/timehash/README
@@ -0,0 +1,4 @@
+timehash is an algorithm (with multiple reference implementations) for
+calculating variable precision sliding windows of time. When performing
+aggregations and correlations on large-scale data sets, the ability to convert
+precise time values into 'malleable intervals' allows for many novel analytics.
diff --git a/python/timehash/slack-desc b/python/timehash/slack-desc
new file mode 100644
index 0000000000..51d4ffb25d
--- /dev/null
+++ b/python/timehash/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+timehash: timehash (module to decode/encode timehashes)
+timehash:
+timehash: timehash is an algorithm (with multiple reference implementations)
+timehash: for calculating variable precision sliding windows of time. When
+timehash: performing aggregations and correlations on large-scale data sets,
+timehash: the ability to convert precise time values into 'malleable intervals'
+timehash: allows for many novel analytics.
+timehash:
+timehash:
+timehash:
+timehash:
diff --git a/python/timehash/timehash.SlackBuild b/python/timehash/timehash.SlackBuild
new file mode 100644
index 0000000000..17efab1989
--- /dev/null
+++ b/python/timehash/timehash.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for timehash
+
+# Copyright 2016 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=timehash
+VERSION=${VERSION:-1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
+ grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.md CONTRIBUTORS.md LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/timehash/timehash.info b/python/timehash/timehash.info
new file mode 100644
index 0000000000..0a135ebfc8
--- /dev/null
+++ b/python/timehash/timehash.info
@@ -0,0 +1,10 @@
+PRGNAM="timehash"
+VERSION="1.1"
+HOMEPAGE="https://github.com/abeusher/timehash"
+DOWNLOAD="https://pypi.python.org/packages/source/t/timehash/timehash-1.1.tar.gz"
+MD5SUM="04168c401cd1114fa8784242ad3f6d6d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"