summaryrefslogtreecommitdiffstats
path: root/python/terminado
diff options
context:
space:
mode:
author Isaac Yu2022-05-28 08:03:36 +0200
committer Willy Sudiarto Raharjo2022-06-04 05:37:20 +0200
commit03f0407421931694a713f51b16813202ec2d44fb (patch)
tree7d3330e5d4006baa8fb6d8ee2da9442cfd0d6db6 /python/terminado
parent62b9e2ac1fbe53ac35e3770d6e546c23ec72c038 (diff)
downloadslackbuilds-03f0407421931694a713f51b16813202ec2d44fb.tar.gz
python/terminado: Update for 0.15.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/terminado')
-rw-r--r--python/terminado/terminado.SlackBuild18
-rw-r--r--python/terminado/terminado.info6
2 files changed, 19 insertions, 5 deletions
diff --git a/python/terminado/terminado.SlackBuild b/python/terminado/terminado.SlackBuild
index 1316ea5b80..a9b355606d 100644
--- a/python/terminado/terminado.SlackBuild
+++ b/python/terminado/terminado.SlackBuild
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=terminado
-VERSION=${VERSION:-0.13.3}
+VERSION=${VERSION:-0.15.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,7 +80,21 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# Use this setup.py shim:
+cat << EOF > setup.py
+from setuptools import setup, find_packages
+setup(name='${PRGNAM}',
+ version='${VERSION}',
+ packages=find_packages(),
+ package_data={'': ['*'], 'terminado': ['_static/*']},
+ install_requires=["ptyprocess;os_name!='nt'", "pywinpty>=1.1.0;os_name=='nt'", "tornado>=6.1.0"],
+ extras_require={'test': ['pytest']},
+)
+EOF
+
+# With the shim, it's a good idea to use "unshare -n" to prevent downloading
+# anything extra:
+unshare -n python3 setup.py install --root=$PKG || exit 1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/terminado/terminado.info b/python/terminado/terminado.info
index ef0cdac6f2..40f1a6f531 100644
--- a/python/terminado/terminado.info
+++ b/python/terminado/terminado.info
@@ -1,8 +1,8 @@
PRGNAM="terminado"
-VERSION="0.13.3"
+VERSION="0.15.0"
HOMEPAGE="https://github.com/jupyter/terminado"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/t/terminado/terminado-0.13.3.tar.gz"
-MD5SUM="2847ae71834cf485432e58d40973920e"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/t/terminado/terminado-0.15.0.tar.gz"
+MD5SUM="e3fe92b48b3885ffa19b9890ed41578f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-ptyprocess python3-tornado"