summaryrefslogtreecommitdiffstats
path: root/python/terminado
diff options
context:
space:
mode:
author Dave Woodfall2021-05-21 22:32:25 +0200
committer Willy Sudiarto Raharjo2021-06-01 20:02:29 +0200
commitb422a0d120d95bc16a86d952415f6fe25f3ad375 (patch)
treedf28a13e2efd9e4981106fdebd9a34fd712ec392 /python/terminado
parent4174685dade14e4f0c8864cf26fda562f0eb9a7c (diff)
downloadslackbuilds-b422a0d120d95bc16a86d952415f6fe25f3ad375.tar.gz
python/terminado: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/terminado')
-rw-r--r--python/terminado/README4
-rw-r--r--python/terminado/terminado.SlackBuild1
2 files changed, 3 insertions, 2 deletions
diff --git a/python/terminado/README b/python/terminado/README
index e42d4a4779..54baa522ae 100644
--- a/python/terminado/README
+++ b/python/terminado/README
@@ -1,2 +1,2 @@
-Terminado is a Tornado websocket backend for the term.js Javascript terminal
-emulator library.
+Terminado is a Tornado websocket backend for the term.js Javascript
+terminal emulator library.
diff --git a/python/terminado/terminado.SlackBuild b/python/terminado/terminado.SlackBuild
index 2e2379347f..81c7ca3a24 100644
--- a/python/terminado/terminado.SlackBuild
+++ b/python/terminado/terminado.SlackBuild
@@ -69,6 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \