summaryrefslogtreecommitdiffstats
path: root/python/tagpy
diff options
context:
space:
mode:
author Robby Workman2013-11-17 03:25:16 +0100
committer Robby Workman2013-11-17 03:25:16 +0100
commit34fbb1b72635360962041d82588bf3192b4fa931 (patch)
treee794aa931ea0cd793a8051353d34c404203a3d10 /python/tagpy
parenta135267a52114c9072ba56f00beca771da1fc34e (diff)
downloadslackbuilds-34fbb1b72635360962041d82588bf3192b4fa931.tar.gz
python/tagpy: Removed (build failure ; unused)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/tagpy')
-rw-r--r--python/tagpy/README3
-rw-r--r--python/tagpy/slack-desc19
-rw-r--r--python/tagpy/tagpy.SlackBuild93
-rw-r--r--python/tagpy/tagpy.info10
4 files changed, 0 insertions, 125 deletions
diff --git a/python/tagpy/README b/python/tagpy/README
deleted file mode 100644
index 5ccdaec9ad..0000000000
--- a/python/tagpy/README
+++ /dev/null
@@ -1,3 +0,0 @@
-TagPy is a set of Python bindings for Scott Wheeler's TagLib. It
-builds upon Boost.Python, a wrapper generation library which is
-part of the Boost set of C++ libraries.
diff --git a/python/tagpy/slack-desc b/python/tagpy/slack-desc
deleted file mode 100644
index d4489ebfba..0000000000
--- a/python/tagpy/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-tagpy: TagPy (Python Bindings for TagLib)
-tagpy:
-tagpy: TagPy is a set of Python bindings for Scott Wheeler's TagLib. It
-tagpy: builds upon Boost.Python, a wrapper generation library which is
-tagpy: part of the Boost set of C++ libraries.
-tagpy:
-tagpy: Homepage: http://mathema.tician.de/software/tagpy
-tagpy:
-tagpy:
-tagpy:
-tagpy:
diff --git a/python/tagpy/tagpy.SlackBuild b/python/tagpy/tagpy.SlackBuild
deleted file mode 100644
index 0ca35aa015..0000000000
--- a/python/tagpy/tagpy.SlackBuild
+++ /dev/null
@@ -1,93 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for TagPy
-
-# Copyright 2008 Frank Caraballo <fecaraballo{at}gmail{dot}com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=tagpy
-VERSION=${VERSION:-0.94.5}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-fi
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP || exit 1
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z* || exit 1
-cd $PRGNAM-$VERSION || exit 1
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --boost-inc-dir=/usr/include/boost \
- --boost-lib-dir=/usr/lib \
- --boost-python-libname=boost_python \
- --taglib-inc-dir=/usr/include/taglib \
- || exit 1
-
-python setup.py build || exit 1
-python setup.py install --root $PKG || exit 1
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE PKG-INFO README* \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/tagpy/tagpy.info b/python/tagpy/tagpy.info
deleted file mode 100644
index ae9409f4cb..0000000000
--- a/python/tagpy/tagpy.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="tagpy"
-VERSION="0.94.5"
-HOMEPAGE="http://mathema.tician.de/software/tagpy"
-DOWNLOAD="http://pypi.python.org/packages/source/t/tagpy/tagpy-0.94.5.tar.gz"
-MD5SUM="84d7862786ad7bab91d0d45ded15a875"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pysetuptools"
-MAINTAINER="Frank Caraballo"
-EMAIL="fecaraballo{at}gmail{dot}com"