summaryrefslogtreecommitdiffstats
path: root/python/subprocess32
diff options
context:
space:
mode:
author Serban Udrea2018-10-30 16:08:29 +0100
committer Willy Sudiarto Raharjo2018-11-03 01:44:57 +0100
commit725266d352efc19cde7e2dfa246ac99c7a94c4bd (patch)
tree041da1fc162e6871c129b084c06de70fce7c3bb2 /python/subprocess32
parent57ae9b895b2f6ccb5f21a249f9828587368027fc (diff)
downloadslackbuilds-725266d352efc19cde7e2dfa246ac99c7a94c4bd.tar.gz
python/subprocess32: Added (subprocess module).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/subprocess32')
-rw-r--r--python/subprocess32/README6
-rw-r--r--python/subprocess32/slack-desc19
-rw-r--r--python/subprocess32/subprocess32.SlackBuild72
-rw-r--r--python/subprocess32/subprocess32.info10
4 files changed, 107 insertions, 0 deletions
diff --git a/python/subprocess32/README b/python/subprocess32/README
new file mode 100644
index 0000000000..802a975a33
--- /dev/null
+++ b/python/subprocess32/README
@@ -0,0 +1,6 @@
+This is a backport of the subprocess standard library module from Python 3.2-3.5
+for use on Python 2.
+
+It includes bugfixes and some new features. On POSIX systems it is guaranteed to
+be reliable when used in threaded applications. It includes timeout support from
+Python 3.3 and the run() API from 3.5 but otherwise matches 3.2’s API.
diff --git a/python/subprocess32/slack-desc b/python/subprocess32/slack-desc
new file mode 100644
index 0000000000..86d5e63c37
--- /dev/null
+++ b/python/subprocess32/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+subprocess32: subprocess32 (backport of Python's 3 subprocess module)
+subprocess32:
+subprocess32: The subprocess32 python module is a backport of the subprocess
+subprocess32: standard library module from Python 3.2-3.5 for use on Python 2.
+subprocess32:
+subprocess32:
+subprocess32:
+subprocess32: Homepage: https://pypi.org/project/subprocess32
+subprocess32:
+subprocess32:
+subprocess32:
diff --git a/python/subprocess32/subprocess32.SlackBuild b/python/subprocess32/subprocess32.SlackBuild
new file mode 100644
index 0000000000..3bbf5bb4a3
--- /dev/null
+++ b/python/subprocess32/subprocess32.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for subprocess32
+
+# Copyright 2018 Serban Udrea <s.udrea@gsi.de>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification,
+# is permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR
+# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT,
+# INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
+# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+# POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=subprocess32
+VERSION=${VERSION:-3.5.2}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root $PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README.md ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/subprocess32/subprocess32.info b/python/subprocess32/subprocess32.info
new file mode 100644
index 0000000000..d9dfc0e540
--- /dev/null
+++ b/python/subprocess32/subprocess32.info
@@ -0,0 +1,10 @@
+PRGNAM="subprocess32"
+VERSION="3.5.2"
+HOMEPAGE="https://pypi.org/project/subprocess32"
+DOWNLOAD="https://files.pythonhosted.org/packages/c3/5f/7117737fc7114061837a4f51670d863dd7f7f9c762a6546fa8a0dcfe61c8/subprocess32-3.5.2.tar.gz"
+MD5SUM="4bd55a9fe9504a683255c4f51b1679ae"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Serban Udrea"
+EMAIL="S.Udrea@gsi.de"