summaryrefslogtreecommitdiffstats
path: root/python/snowballstemmer/snowballstemmer.SlackBuild
diff options
context:
space:
mode:
author Nikos Giotis2018-02-13 17:45:58 +0100
committer Willy Sudiarto Raharjo2018-02-17 01:42:55 +0100
commit44f5e093bb02394fd73d8a16e32a009a85392446 (patch)
treee27c5f42ebd62a2c69c95067419bc08cd81c3dd5 /python/snowballstemmer/snowballstemmer.SlackBuild
parent5210399b24831d3168a517beba4757c3ffb45f34 (diff)
downloadslackbuilds-44f5e093bb02394fd73d8a16e32a009a85392446.tar.gz
python/snowballstemmer: Add python3 support.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/snowballstemmer/snowballstemmer.SlackBuild')
-rw-r--r--python/snowballstemmer/snowballstemmer.SlackBuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/python/snowballstemmer/snowballstemmer.SlackBuild b/python/snowballstemmer/snowballstemmer.SlackBuild
index fc7db032be..9be1e48385 100644
--- a/python/snowballstemmer/snowballstemmer.SlackBuild
+++ b/python/snowballstemmer/snowballstemmer.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for snowballstemmer
-# Copyright 2017 Nikos Giotis <nikos.giotis@gmail.com>
+# Copyright 2017,2018 Nikos Giotis <nikos.giotis@gmail.com>, Athens, GR
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=snowballstemmer
VERSION=${VERSION:-1.2.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -70,6 +70,9 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true