summaryrefslogtreecommitdiffstats
path: root/python/six
diff options
context:
space:
mode:
author Larry Hajali2013-10-28 01:14:57 +0100
committer Robby Workman2013-10-28 05:39:07 +0100
commit8d6b92b9ccd3553eac6ffa2648df5f898f3bb99a (patch)
tree7ef8368e855bf58e236688aec6e71a7087765cc3 /python/six
parentd29439228c92391ae0293ceecf9d8e760e7462b9 (diff)
downloadslackbuilds-8d6b92b9ccd3553eac6ffa2648df5f898f3bb99a.tar.gz
python/six: Updated for version 1.4.1.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/six')
-rw-r--r--python/six/README2
-rw-r--r--python/six/six.SlackBuild8
-rw-r--r--python/six/six.info6
3 files changed, 10 insertions, 6 deletions
diff --git a/python/six/README b/python/six/README
index 35001d4d34..865f5c9b24 100644
--- a/python/six/README
+++ b/python/six/README
@@ -4,4 +4,4 @@ writing Python code that is compatible on both Python versions. See the
documentation for more information on what is provided.
Optional: html documentation and man pages will be installed if Pygments and
-Sphinx are installed.
+Sphinx are installed. Python3 module will be built if Python3 is installed.
diff --git a/python/six/six.SlackBuild b/python/six/six.SlackBuild
index 0ccf1936b7..b7cb56668f 100644
--- a/python/six/six.SlackBuild
+++ b/python/six/six.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for six
-# Copyright 2012 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=six
-VERSION=${VERSION:-1.3.0}
+VERSION=${VERSION:-1.4.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,6 +57,10 @@ find . \
python setup.py install --root=$PKG
+if $(python3 -c 'import os' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/six/six.info b/python/six/six.info
index a14252bda2..ca67fc4b70 100644
--- a/python/six/six.info
+++ b/python/six/six.info
@@ -1,8 +1,8 @@
PRGNAM="six"
-VERSION="1.3.0"
+VERSION="1.4.1"
HOMEPAGE="http://pypi.python.org/pypi/six/"
-DOWNLOAD="http://pypi.python.org/packages/source/s/six/six-1.3.0.tar.gz"
-MD5SUM="ec47fe6070a8a64c802363d2c2b1e2ee"
+DOWNLOAD="http://pypi.python.org/packages/source/s/six/six-1.4.1.tar.gz"
+MD5SUM="bdbb9e12d3336c198695aa4cf3a61d62"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""