summaryrefslogtreecommitdiffstats
path: root/python/sippy
diff options
context:
space:
mode:
author Nikolay Korotkiy2013-02-11 22:00:35 +0100
committer Erik Hanson2013-02-14 07:26:56 +0100
commit547f71171b59c92f515179fdb6a4d32611c37702 (patch)
tree3ac7cf623b0de4eeaef8b887363d2338b22c3924 /python/sippy
parentc9812f9c85ec97d194adef048be53d51dc0df919 (diff)
downloadslackbuilds-547f71171b59c92f515179fdb6a4d32611c37702.tar.gz
python/sippy: Added (Sippy B2BUA)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'python/sippy')
-rw-r--r--python/sippy/README14
-rw-r--r--python/sippy/setup.patch9
-rw-r--r--python/sippy/sippy.SlackBuild72
-rw-r--r--python/sippy/sippy.info10
-rw-r--r--python/sippy/slack-desc19
5 files changed, 124 insertions, 0 deletions
diff --git a/python/sippy/README b/python/sippy/README
new file mode 100644
index 0000000000..5a6f123d12
--- /dev/null
+++ b/python/sippy/README
@@ -0,0 +1,14 @@
+Sippy B2BUA is a RFC3261-compliant Session Initiation Protocol (SIP)
+Back-to-back user agent (B2BUA) server software.
+
+The B2BUA is a SIP call controlling component. Unlike a SIP proxy server,
+which only maintains transaction state, the B2BUA maintains complete call
+state and participates in all call requests. For this reason it can perform
+number of functions that are not possible to implement using SIP proxy, such
+as for example accurate call accounting, pre-paid rating and billing, fail
+over call routing etc. Unlike PBX-type solutions such as Asterisk for example,
+the B2BUA doesn't perform any media relaying or processing, therefore it
+doesn't introduce any additional packet loss, delay or jitter into the
+media path.
+
+The Sippy B2BUA is distributed under version 2 of GNU Public License (GPL).
diff --git a/python/sippy/setup.patch b/python/sippy/setup.patch
new file mode 100644
index 0000000000..d4ecd0946e
--- /dev/null
+++ b/python/sippy/setup.patch
@@ -0,0 +1,9 @@
+--- setup.py 2009-12-01 07:58:44.000000000 +0300
++++ setup.py.new 2013-01-16 17:55:50.000000000 +0400
+@@ -36,5 +36,4 @@
+ url = 'http://www.b2bua.org/',
+ packages = ['sippy'],
+ scripts = ['sippy/b2bua_radius.py', 'sippy/b2bua_simple.py'],
+- data_files = [('etc/sippy', ['sippy/dictionary']),
+- ('share/doc/sippy', ['COPYING'])])
++ data_files = [('etc/sippy', ['sippy/dictionary']),])
diff --git a/python/sippy/sippy.SlackBuild b/python/sippy/sippy.SlackBuild
new file mode 100644
index 0000000000..bb93b55254
--- /dev/null
+++ b/python/sippy/sippy.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for sippy
+
+# Copyright 2013, Nikolay Korotkiy <sikmir@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=sippy
+VERSION=${VERSION:-1.0.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -eu
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+patch -p0 < $CWD/setup.patch
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/sippy/sippy.info b/python/sippy/sippy.info
new file mode 100644
index 0000000000..f3b8090b7a
--- /dev/null
+++ b/python/sippy/sippy.info
@@ -0,0 +1,10 @@
+PRGNAM="sippy"
+VERSION="1.0.3"
+HOMEPAGE="http://www.b2bua.org"
+DOWNLOAD="http://b2bua.org/chrome/site/sippy-1.0.3.tar.gz"
+MD5SUM="588a418e6a15c25eebd06bfb8fed81de"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Nikolay Korotkiy"
+EMAIL="sikmir@gmail.com"
diff --git a/python/sippy/slack-desc b/python/sippy/slack-desc
new file mode 100644
index 0000000000..b3b23060b1
--- /dev/null
+++ b/python/sippy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+sippy: sippy (Sippy B2BUA)
+sippy:
+sippy: Sippy B2BUA is a RFC3261-compliant Session Initiation Protocol (SIP)
+sippy: Back-to-back user agent (B2BUA) server software.
+sippy:
+sippy:
+sippy:
+sippy:
+sippy: Homepage: http://www.b2bua.org
+sippy:
+sippy: