summaryrefslogtreecommitdiffstats
path: root/python/shutilwhich
diff options
context:
space:
mode:
author Markus Reichelt2016-10-23 02:01:54 +0200
committer Willy Sudiarto Raharjo2016-10-23 02:10:47 +0200
commita2e7799567b9419f430970bb66adb1f67d3256be (patch)
treefc14a96bf343b606176ce572e724caa418a99bde /python/shutilwhich
parent3e45fa2db6f87022770acc299c29ee6fa28e1beb (diff)
downloadslackbuilds-a2e7799567b9419f430970bb66adb1f67d3256be.tar.gz
python/shutilwhich: Added (shutil.which backport from Python 3.3).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/shutilwhich')
-rw-r--r--python/shutilwhich/README3
-rw-r--r--python/shutilwhich/shutilwhich.SlackBuild86
-rw-r--r--python/shutilwhich/shutilwhich.info10
-rw-r--r--python/shutilwhich/slack-desc19
4 files changed, 118 insertions, 0 deletions
diff --git a/python/shutilwhich/README b/python/shutilwhich/README
new file mode 100644
index 0000000000..5c58385a48
--- /dev/null
+++ b/python/shutilwhich/README
@@ -0,0 +1,3 @@
+A copy & paste backport of Python 3.3's shutil.which function.
+On Python 3.3 and above, the module never does anything but
+return the stdlib shutil.which function.
diff --git a/python/shutilwhich/shutilwhich.SlackBuild b/python/shutilwhich/shutilwhich.SlackBuild
new file mode 100644
index 0000000000..c18a44b839
--- /dev/null
+++ b/python/shutilwhich/shutilwhich.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for shutilwhich
+#
+# Copyright 2016 Markus Reichelt, Aachen, DE
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=shutilwhich
+VERSION=${VERSION:-1.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/shutilwhich/shutilwhich.info b/python/shutilwhich/shutilwhich.info
new file mode 100644
index 0000000000..48f384a1c9
--- /dev/null
+++ b/python/shutilwhich/shutilwhich.info
@@ -0,0 +1,10 @@
+PRGNAM="shutilwhich"
+VERSION="1.1.0"
+HOMEPAGE="https://pypi.python.org/pypi/shutilwhich"
+DOWNLOAD="https://pypi.python.org/packages/66/be/783f181594bb8bcfde174d6cd1e41956b986d0d8d337d535eb2555b92f8d/shutilwhich-1.1.0.tar.gz"
+MD5SUM="915947c5cdae7afd748ac715ee547adb"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Markus Reichelt"
+EMAIL="slackbuilds@mareichelt.de"
diff --git a/python/shutilwhich/slack-desc b/python/shutilwhich/slack-desc
new file mode 100644
index 0000000000..9aeb7b1954
--- /dev/null
+++ b/python/shutilwhich/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+shutilwhich: shutilwhich (shutil.which backport from Python 3.3)
+shutilwhich:
+shutilwhich: A copy & paste backport of Python 3.3's shutil.which function.
+shutilwhich:
+shutilwhich: https://pypi.python.org/pypi/shutilwhich
+shutilwhich:
+shutilwhich:
+shutilwhich:
+shutilwhich:
+shutilwhich:
+shutilwhich: