summaryrefslogtreecommitdiffstats
path: root/python/shutil_get_terminal_size
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2017-01-23 18:23:33 +0100
committer David Spencer2017-01-24 01:21:53 +0100
commit34043e1f6c29052ced1ea11662f103bb52107def (patch)
tree9c347652ceb25f5fe560dda6cb29c0d47a2988ef /python/shutil_get_terminal_size
parent4f8cbe143cd4c103731435b685abebed111ad3c9 (diff)
downloadslackbuilds-34043e1f6c29052ced1ea11662f103bb52107def.tar.gz
python/shutil_get_terminal_size: Added (get size of term window).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/shutil_get_terminal_size')
-rw-r--r--python/shutil_get_terminal_size/README1
-rw-r--r--python/shutil_get_terminal_size/shutil_get_terminal_size.SlackBuild88
-rw-r--r--python/shutil_get_terminal_size/shutil_get_terminal_size.info10
-rw-r--r--python/shutil_get_terminal_size/slack-desc19
4 files changed, 118 insertions, 0 deletions
diff --git a/python/shutil_get_terminal_size/README b/python/shutil_get_terminal_size/README
new file mode 100644
index 0000000000..36868c27f8
--- /dev/null
+++ b/python/shutil_get_terminal_size/README
@@ -0,0 +1 @@
+A backport of the get_terminal_size function from Python 3.3's shutil.
diff --git a/python/shutil_get_terminal_size/shutil_get_terminal_size.SlackBuild b/python/shutil_get_terminal_size/shutil_get_terminal_size.SlackBuild
new file mode 100644
index 0000000000..9239376223
--- /dev/null
+++ b/python/shutil_get_terminal_size/shutil_get_terminal_size.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for shutil_get_terminal_size
+
+# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=shutil_get_terminal_size
+SRCNAM=backports.$PRGNAM
+VERSION=${VERSION:-1.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ HISTORY.rst LICENSE README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/shutil_get_terminal_size/shutil_get_terminal_size.info b/python/shutil_get_terminal_size/shutil_get_terminal_size.info
new file mode 100644
index 0000000000..939631831a
--- /dev/null
+++ b/python/shutil_get_terminal_size/shutil_get_terminal_size.info
@@ -0,0 +1,10 @@
+PRGNAM="shutil_get_terminal_size"
+VERSION="1.0.0"
+HOMEPAGE="https://jupyter.org/"
+DOWNLOAD="https://github.com/chrippa/backports.shutil_get_terminal_size/archive/v1.0.0/backports.shutil_get_terminal_size-1.0.0.tar.gz"
+MD5SUM="82499a36a98dd7ed37c8678e6002a375"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/shutil_get_terminal_size/slack-desc b/python/shutil_get_terminal_size/slack-desc
new file mode 100644
index 0000000000..b5c93dec48
--- /dev/null
+++ b/python/shutil_get_terminal_size/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+shutil_get_terminal_size: shutil_get_terminal_size (get the size of the terminal window)
+shutil_get_terminal_size:
+shutil_get_terminal_size: A backport of the get_terminal_size function from Python 3.3's
+shutil_get_terminal_size: shutil.
+shutil_get_terminal_size:
+shutil_get_terminal_size:
+shutil_get_terminal_size:
+shutil_get_terminal_size:
+shutil_get_terminal_size:
+shutil_get_terminal_size:
+shutil_get_terminal_size: