summaryrefslogtreecommitdiffstats
path: root/python/scikit-umfpack
diff options
context:
space:
mode:
author B. Watson2023-05-16 04:17:36 +0200
committer Willy Sudiarto Raharjo2023-05-20 06:17:40 +0200
commitb48b38dce5f7d2d7f9ebc70d074cd05f4a8b1ce1 (patch)
tree8a221465b41b27548da9a63a7fc1f1acfbc680df /python/scikit-umfpack
parent4d360c4e8aebe4883cb1a3fa560235493db82983 (diff)
downloadslackbuilds-b48b38dce5f7d2d7f9ebc70d074cd05f4a8b1ce1.tar.gz
python/scikit-umfpack: Align with template.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/scikit-umfpack')
-rw-r--r--python/scikit-umfpack/scikit-umfpack.SlackBuild26
1 files changed, 11 insertions, 15 deletions
diff --git a/python/scikit-umfpack/scikit-umfpack.SlackBuild b/python/scikit-umfpack/scikit-umfpack.SlackBuild
index 0f99851f43..0ba4018e1f 100644
--- a/python/scikit-umfpack/scikit-umfpack.SlackBuild
+++ b/python/scikit-umfpack/scikit-umfpack.SlackBuild
@@ -22,6 +22,9 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#### 20230515 bkw: Modified by SlackBuilds.org. See section beginning
+#### with "NOT ALLOWED", below.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=scikit-umfpack
@@ -38,15 +41,12 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-TMP=${TMP:-/tmp}
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -79,7 +79,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
+#### 20230515 bkw: This is NOT ALLOWED. Modifying files in the real
+#### /usr, outside of $PKG, is forbidden. SlackBuilds may not do this.
+#### Fix this. Ideally, get the umfpack maintainer to fix it in that
+#### build, since system headers should not use "blah.h" for includes.
( if [ -f /usr/include/umfpack/umfpack.h ]; then
echo "umfpack detected."
echo
@@ -90,17 +93,10 @@ find -L . \
find . -type f -name "umfpack.h" -print0 | xargs -0 sed -i 's/#include "amd.h"/#include <amd\/amd.h>/g'
fi )
-# Python 2.7 will be droped in the future.
-if $(python2 -c 'import sys' 2>/dev/null); then
- python2 setup.py install --root=$PKG
- else
- python setup.py install --root=$PKG
-fi
+# Python 2.7 will be dropped in the future.
+python2 setup.py install --root=$PKG
-# Replacement of python-2.x Python3.x check presence and build if found.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true