summaryrefslogtreecommitdiffstats
path: root/python/pyutil
diff options
context:
space:
mode:
author Markus Reichelt2013-12-27 01:15:00 +0100
committer Erik Hanson2014-01-07 18:13:56 +0100
commite9f10174ebd97bc2aaa5ba75e70652b7c6765d93 (patch)
treecc9a773a742197b3ca908b2632f38b9a60a448ee /python/pyutil
parenta5c73390fe53752fbff1776c8efaf6c8f851878e (diff)
downloadslackbuilds-e9f10174ebd97bc2aaa5ba75e70652b7c6765d93.tar.gz
python/pyutil: Updated for version 1.9.7.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pyutil')
-rw-r--r--python/pyutil/README3
-rw-r--r--python/pyutil/pyutil.SlackBuild19
-rw-r--r--python/pyutil/pyutil.info6
3 files changed, 18 insertions, 10 deletions
diff --git a/python/pyutil/README b/python/pyutil/README
index 068d92ea85..d891b90edc 100644
--- a/python/pyutil/README
+++ b/python/pyutil/README
@@ -1 +1,2 @@
-A collection of functions and data structures from allmydata.org.
+A collection of functions and data structures from tahoe-lafs.org
+(formerly allmydata.org).
diff --git a/python/pyutil/pyutil.SlackBuild b/python/pyutil/pyutil.SlackBuild
index 94c9ca2b03..7123a6d638 100644
--- a/python/pyutil/pyutil.SlackBuild
+++ b/python/pyutil/pyutil.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for pyutil.
# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
-# Copyright 2012 Markus Reichelt, Aachen, DE
+# Copyright 2012-2013 Markus Reichelt, Stolberg (Rhld.), DE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,7 +27,7 @@
# Now maintained by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
PRGNAM=pyutil
-VERSION=${VERSION:-1.9.3}
+VERSION=${VERSION:-1.9.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -46,12 +46,19 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
+
set -e
rm -rf $PKG
@@ -62,10 +69,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
diff --git a/python/pyutil/pyutil.info b/python/pyutil/pyutil.info
index 0b5a95bd7e..eaffa167c4 100644
--- a/python/pyutil/pyutil.info
+++ b/python/pyutil/pyutil.info
@@ -1,8 +1,8 @@
PRGNAM="pyutil"
-VERSION="1.9.3"
+VERSION="1.9.7"
HOMEPAGE="http://pypi.python.org/pypi/pyutil"
-DOWNLOAD="http://pypi.python.org/packages/source/p/pyutil/pyutil-1.9.3.tar.gz"
-MD5SUM="3902a6ad6772eebc347cfcca41d1b63f"
+DOWNLOAD="http://pypi.python.org/packages/source/p/pyutil/pyutil-1.9.7.tar.gz"
+MD5SUM="5a20ccae479d967d3fa11b905d0e10f6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="zbase32"