summaryrefslogtreecommitdiffstats
path: root/python/python3/patches
diff options
context:
space:
mode:
author Audrius Kažukauskas2015-03-01 21:20:28 +0100
committer Willy Sudiarto Raharjo2015-03-08 00:35:07 +0100
commit488a866d870abcaa6cf1aa1b165136a20361fabc (patch)
tree5a2c423bde2329e93b138d25ee5211c6a2bde274 /python/python3/patches
parente7f9c311f6a69fd909fab4c2c641fd3b3e8f05e7 (diff)
downloadslackbuilds-488a866d870abcaa6cf1aa1b165136a20361fabc.tar.gz
python/python3: Updated for version 3.4.3.
Signed-off-by: Audrius Kažukauskas <audrius@neutrino.lt>
Diffstat (limited to 'python/python3/patches')
-rw-r--r--python/python3/patches/python3.no-static-library.diff14
-rw-r--r--python/python3/patches/python3.x86_64.diff50
2 files changed, 32 insertions, 32 deletions
diff --git a/python/python3/patches/python3.no-static-library.diff b/python/python3/patches/python3.no-static-library.diff
index 442373021c..fa3a36b9d5 100644
--- a/python/python3/patches/python3.no-static-library.diff
+++ b/python/python3/patches/python3.no-static-library.diff
@@ -1,7 +1,7 @@
-diff -uar Python-3.4.2.orig/Makefile.pre.in Python-3.4.2/Makefile.pre.in
---- Python-3.4.2.orig/Makefile.pre.in 2014-10-08 11:18:14.000000000 +0300
-+++ Python-3.4.2/Makefile.pre.in 2014-10-09 21:12:08.504150485 +0300
-@@ -537,7 +537,7 @@
+diff -uar Python-3.4.3.orig/Makefile.pre.in Python-3.4.3/Makefile.pre.in
+--- Python-3.4.3.orig/Makefile.pre.in 2015-02-25 13:27:45.000000000 +0200
++++ Python-3.4.3/Makefile.pre.in 2015-02-25 21:29:01.322056319 +0200
+@@ -538,7 +538,7 @@
$(RUNSHARED) $(PYTHON_FOR_BUILD) ./Tools/clinic/clinic.py --make
# Build the interpreter
@@ -10,7 +10,7 @@ diff -uar Python-3.4.2.orig/Makefile.pre.in Python-3.4.2/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
platform: $(BUILDPYTHON) pybuilddir.txt
-@@ -572,18 +572,6 @@
+@@ -573,18 +573,6 @@
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
@@ -29,7 +29,7 @@ diff -uar Python-3.4.2.orig/Makefile.pre.in Python-3.4.2/Makefile.pre.in
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-@@ -673,7 +661,7 @@
+@@ -674,7 +662,7 @@
echo "-----------------------------------------------"; \
fi
@@ -38,7 +38,7 @@ diff -uar Python-3.4.2.orig/Makefile.pre.in Python-3.4.2/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
############################################################################
-@@ -1324,18 +1312,6 @@
+@@ -1325,18 +1313,6 @@
else true; \
fi; \
done
diff --git a/python/python3/patches/python3.x86_64.diff b/python/python3/patches/python3.x86_64.diff
index 0f144044e3..6d03183149 100644
--- a/python/python3/patches/python3.x86_64.diff
+++ b/python/python3/patches/python3.x86_64.diff
@@ -1,6 +1,6 @@
-diff -uar Python-3.4.2.orig/Lib/distutils/command/install.py Python-3.4.2/Lib/distutils/command/install.py
---- Python-3.4.2.orig/Lib/distutils/command/install.py 2014-10-08 11:18:12.000000000 +0300
-+++ Python-3.4.2/Lib/distutils/command/install.py 2014-10-09 21:15:42.705228065 +0300
+diff -uar Python-3.4.3.orig/Lib/distutils/command/install.py Python-3.4.3/Lib/distutils/command/install.py
+--- Python-3.4.3.orig/Lib/distutils/command/install.py 2015-02-25 13:27:44.000000000 +0200
++++ Python-3.4.3/Lib/distutils/command/install.py 2015-02-25 21:32:54.352351233 +0200
@@ -29,15 +29,15 @@
INSTALL_SCHEMES = {
@@ -21,9 +21,9 @@ diff -uar Python-3.4.2.orig/Lib/distutils/command/install.py Python-3.4.2/Lib/di
'headers': '$base/include/python/$dist_name',
'scripts': '$base/bin',
'data' : '$base',
-diff -uar Python-3.4.2.orig/Lib/distutils/sysconfig.py Python-3.4.2/Lib/distutils/sysconfig.py
---- Python-3.4.2.orig/Lib/distutils/sysconfig.py 2014-10-08 11:18:12.000000000 +0300
-+++ Python-3.4.2/Lib/distutils/sysconfig.py 2014-10-09 21:15:42.705228065 +0300
+diff -uar Python-3.4.3.orig/Lib/distutils/sysconfig.py Python-3.4.3/Lib/distutils/sysconfig.py
+--- Python-3.4.3.orig/Lib/distutils/sysconfig.py 2015-02-25 13:27:44.000000000 +0200
++++ Python-3.4.3/Lib/distutils/sysconfig.py 2015-02-25 21:32:54.352351233 +0200
@@ -142,7 +142,7 @@
if os.name == "posix":
@@ -33,9 +33,9 @@ diff -uar Python-3.4.2.orig/Lib/distutils/sysconfig.py Python-3.4.2/Lib/distutil
if standard_lib:
return libpython
else:
-diff -uar Python-3.4.2.orig/Lib/site.py Python-3.4.2/Lib/site.py
---- Python-3.4.2.orig/Lib/site.py 2014-10-08 11:18:12.000000000 +0300
-+++ Python-3.4.2/Lib/site.py 2014-10-09 21:15:42.706228092 +0300
+diff -uar Python-3.4.3.orig/Lib/site.py Python-3.4.3/Lib/site.py
+--- Python-3.4.3.orig/Lib/site.py 2015-02-25 13:27:44.000000000 +0200
++++ Python-3.4.3/Lib/site.py 2015-02-25 21:32:54.353351252 +0200
@@ -304,13 +304,13 @@
seen.add(prefix)
@@ -52,9 +52,9 @@ diff -uar Python-3.4.2.orig/Lib/site.py Python-3.4.2/Lib/site.py
if sys.platform == "darwin":
# for framework builds *only* we add the standard Apple
# locations.
-diff -uar Python-3.4.2.orig/Lib/sysconfig.py Python-3.4.2/Lib/sysconfig.py
---- Python-3.4.2.orig/Lib/sysconfig.py 2014-10-08 11:18:12.000000000 +0300
-+++ Python-3.4.2/Lib/sysconfig.py 2014-10-09 21:15:42.706228092 +0300
+diff -uar Python-3.4.3.orig/Lib/sysconfig.py Python-3.4.3/Lib/sysconfig.py
+--- Python-3.4.3.orig/Lib/sysconfig.py 2015-02-25 13:27:44.000000000 +0200
++++ Python-3.4.3/Lib/sysconfig.py 2015-02-25 21:32:54.353351252 +0200
@@ -20,10 +20,10 @@
_INSTALL_SCHEMES = {
@@ -100,9 +100,9 @@ diff -uar Python-3.4.2.orig/Lib/sysconfig.py Python-3.4.2/Lib/sysconfig.py
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
'data': '{userbase}',
-diff -uar Python-3.4.2.orig/Makefile.pre.in Python-3.4.2/Makefile.pre.in
---- Python-3.4.2.orig/Makefile.pre.in 2014-10-08 11:18:14.000000000 +0300
-+++ Python-3.4.2/Makefile.pre.in 2014-10-09 21:15:42.707228121 +0300
+diff -uar Python-3.4.3.orig/Makefile.pre.in Python-3.4.3/Makefile.pre.in
+--- Python-3.4.3.orig/Makefile.pre.in 2015-02-25 13:27:45.000000000 +0200
++++ Python-3.4.3/Makefile.pre.in 2015-02-25 21:32:54.354351276 +0200
@@ -120,7 +120,7 @@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
@@ -112,9 +112,9 @@ diff -uar Python-3.4.2.orig/Makefile.pre.in Python-3.4.2/Makefile.pre.in
ABIFLAGS= @ABIFLAGS@
# Detailed destination directories
-diff -uar Python-3.4.2.orig/Modules/getpath.c Python-3.4.2/Modules/getpath.c
---- Python-3.4.2.orig/Modules/getpath.c 2014-10-08 11:18:15.000000000 +0300
-+++ Python-3.4.2/Modules/getpath.c 2014-10-09 21:15:42.707228121 +0300
+diff -uar Python-3.4.3.orig/Modules/getpath.c Python-3.4.3/Modules/getpath.c
+--- Python-3.4.3.orig/Modules/getpath.c 2015-02-25 13:27:46.000000000 +0200
++++ Python-3.4.3/Modules/getpath.c 2015-02-25 21:32:54.354351276 +0200
@@ -118,8 +118,8 @@
#endif
@@ -153,10 +153,10 @@ diff -uar Python-3.4.2.orig/Modules/getpath.c Python-3.4.2/Modules/getpath.c
}
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
-diff -uar Python-3.4.2.orig/configure Python-3.4.2/configure
---- Python-3.4.2.orig/configure 2014-10-08 11:18:16.000000000 +0300
-+++ Python-3.4.2/configure 2014-10-09 21:15:42.711228262 +0300
-@@ -13948,7 +13948,7 @@
+diff -uar Python-3.4.3.orig/configure Python-3.4.3/configure
+--- Python-3.4.3.orig/configure 2015-02-25 13:27:46.000000000 +0200
++++ Python-3.4.3/configure 2015-02-25 21:32:54.358351377 +0200
+@@ -14022,7 +14022,7 @@
$as_echo "$LDVERSION" >&6; }
@@ -165,9 +165,9 @@ diff -uar Python-3.4.2.orig/configure Python-3.4.2/configure
# Check whether right shifting a negative integer extends the sign bit
-diff -uar Python-3.4.2.orig/setup.py Python-3.4.2/setup.py
---- Python-3.4.2.orig/setup.py 2014-10-08 11:18:16.000000000 +0300
-+++ Python-3.4.2/setup.py 2014-10-09 21:15:42.712228293 +0300
+diff -uar Python-3.4.3.orig/setup.py Python-3.4.3/setup.py
+--- Python-3.4.3.orig/setup.py 2015-02-25 13:27:46.000000000 +0200
++++ Python-3.4.3/setup.py 2015-02-25 21:32:54.358351377 +0200
@@ -451,7 +451,7 @@
# directories (i.e. '.' and 'Include') must be first. See issue
# 10520.