summaryrefslogtreecommitdiffstats
path: root/python/python3/patches/python3.x86_64.diff
diff options
context:
space:
mode:
author Audrius Kažukauskas2016-12-28 15:46:00 +0100
committer Willy Sudiarto Raharjo2016-12-31 02:22:44 +0100
commite0f817d0c0402871586b88ec6cde58ef0e16e7bb (patch)
treed84e2cdc8f1b73e90c2f7d5db9c706a90ad9d188 /python/python3/patches/python3.x86_64.diff
parent51a755c3ac576163f75698baab6c2ee22298578b (diff)
downloadslackbuilds-e0f817d0c0402871586b88ec6cde58ef0e16e7bb.tar.gz
python/python3: Updated for version 3.6.0.
Signed-off-by: Audrius Kažukauskas <audrius@neutrino.lt>
Diffstat (limited to 'python/python3/patches/python3.x86_64.diff')
-rw-r--r--python/python3/patches/python3.x86_64.diff79
1 files changed, 41 insertions, 38 deletions
diff --git a/python/python3/patches/python3.x86_64.diff b/python/python3/patches/python3.x86_64.diff
index aa318492d7..d6201b4db3 100644
--- a/python/python3/patches/python3.x86_64.diff
+++ b/python/python3/patches/python3.x86_64.diff
@@ -1,6 +1,6 @@
-diff -uar Python-3.5.1.orig/Lib/distutils/command/install.py Python-3.5.1/Lib/distutils/command/install.py
---- Python-3.5.1.orig/Lib/distutils/command/install.py 2015-12-07 03:39:07.000000000 +0200
-+++ Python-3.5.1/Lib/distutils/command/install.py 2015-12-14 21:27:46.083400395 +0200
+diff -uar Python-3.6.0.orig/Lib/distutils/command/install.py Python-3.6.0/Lib/distutils/command/install.py
+--- Python-3.6.0.orig/Lib/distutils/command/install.py 2016-12-23 04:21:19.000000000 +0200
++++ Python-3.6.0/Lib/distutils/command/install.py 2016-12-27 23:23:09.347324233 +0200
@@ -29,15 +29,15 @@
INSTALL_SCHEMES = {
@@ -21,9 +21,9 @@ diff -uar Python-3.5.1.orig/Lib/distutils/command/install.py Python-3.5.1/Lib/di
'headers': '$base/include/python/$dist_name',
'scripts': '$base/bin',
'data' : '$base',
-diff -uar Python-3.5.1.orig/Lib/distutils/sysconfig.py Python-3.5.1/Lib/distutils/sysconfig.py
---- Python-3.5.1.orig/Lib/distutils/sysconfig.py 2015-12-07 03:39:07.000000000 +0200
-+++ Python-3.5.1/Lib/distutils/sysconfig.py 2015-12-14 21:27:46.083400395 +0200
+diff -uar Python-3.6.0.orig/Lib/distutils/sysconfig.py Python-3.6.0/Lib/distutils/sysconfig.py
+--- Python-3.6.0.orig/Lib/distutils/sysconfig.py 2016-12-23 04:21:19.000000000 +0200
++++ Python-3.6.0/Lib/distutils/sysconfig.py 2016-12-27 23:23:45.371557745 +0200
@@ -133,7 +133,7 @@
if os.name == "posix":
@@ -33,21 +33,21 @@ diff -uar Python-3.5.1.orig/Lib/distutils/sysconfig.py Python-3.5.1/Lib/distutil
if standard_lib:
return libpython
else:
-diff -uar Python-3.5.1.orig/Lib/site.py Python-3.5.1/Lib/site.py
---- Python-3.5.1.orig/Lib/site.py 2015-12-07 03:39:08.000000000 +0200
-+++ Python-3.5.1/Lib/site.py 2015-12-14 21:27:46.083400395 +0200
-@@ -303,7 +303,7 @@
+diff -uar Python-3.6.0.orig/Lib/site.py Python-3.6.0/Lib/site.py
+--- Python-3.6.0.orig/Lib/site.py 2016-12-23 04:21:19.000000000 +0200
++++ Python-3.6.0/Lib/site.py 2016-12-27 23:24:50.123773461 +0200
+@@ -304,7 +304,7 @@
seen.add(prefix)
if os.sep == '/':
- sitepackages.append(os.path.join(prefix, "lib",
+ sitepackages.append(os.path.join(prefix, "lib64",
- "python" + sys.version[:3],
+ "python%d.%d" % sys.version_info[:2],
"site-packages"))
else:
-diff -uar Python-3.5.1.orig/Lib/sysconfig.py Python-3.5.1/Lib/sysconfig.py
---- Python-3.5.1.orig/Lib/sysconfig.py 2015-12-07 03:39:08.000000000 +0200
-+++ Python-3.5.1/Lib/sysconfig.py 2015-12-14 21:27:46.084400429 +0200
+diff -uar Python-3.6.0.orig/Lib/sysconfig.py Python-3.6.0/Lib/sysconfig.py
+--- Python-3.6.0.orig/Lib/sysconfig.py 2016-12-23 04:21:19.000000000 +0200
++++ Python-3.6.0/Lib/sysconfig.py 2016-12-27 23:27:39.368563068 +0200
@@ -20,10 +20,10 @@
_INSTALL_SCHEMES = {
@@ -93,10 +93,10 @@ diff -uar Python-3.5.1.orig/Lib/sysconfig.py Python-3.5.1/Lib/sysconfig.py
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
'data': '{userbase}',
-diff -uar Python-3.5.1.orig/Makefile.pre.in Python-3.5.1/Makefile.pre.in
---- Python-3.5.1.orig/Makefile.pre.in 2015-12-07 03:39:09.000000000 +0200
-+++ Python-3.5.1/Makefile.pre.in 2015-12-14 21:27:46.084400429 +0200
-@@ -125,7 +125,7 @@
+diff -uar Python-3.6.0.orig/Makefile.pre.in Python-3.6.0/Makefile.pre.in
+--- Python-3.6.0.orig/Makefile.pre.in 2016-12-23 04:21:21.000000000 +0200
++++ Python-3.6.0/Makefile.pre.in 2016-12-27 23:28:09.024577604 +0200
+@@ -131,7 +131,7 @@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
CONFINCLUDEDIR= $(exec_prefix)/include
@@ -105,10 +105,10 @@ diff -uar Python-3.5.1.orig/Makefile.pre.in Python-3.5.1/Makefile.pre.in
ABIFLAGS= @ABIFLAGS@
# Detailed destination directories
-diff -uar Python-3.5.1.orig/Modules/getpath.c Python-3.5.1/Modules/getpath.c
---- Python-3.5.1.orig/Modules/getpath.c 2015-12-07 03:39:10.000000000 +0200
-+++ Python-3.5.1/Modules/getpath.c 2015-12-14 21:27:46.085400463 +0200
-@@ -511,7 +511,7 @@
+diff -uar Python-3.6.0.orig/Modules/getpath.c Python-3.6.0/Modules/getpath.c
+--- Python-3.6.0.orig/Modules/getpath.c 2016-12-23 04:21:21.000000000 +0200
++++ Python-3.6.0/Modules/getpath.c 2016-12-27 23:30:11.883780781 +0200
+@@ -494,7 +494,7 @@
_pythonpath = Py_DecodeLocale(PYTHONPATH, NULL);
_prefix = Py_DecodeLocale(PREFIX, NULL);
_exec_prefix = Py_DecodeLocale(EXEC_PREFIX, NULL);
@@ -117,7 +117,7 @@ diff -uar Python-3.5.1.orig/Modules/getpath.c Python-3.5.1/Modules/getpath.c
if (!_pythonpath || !_prefix || !_exec_prefix || !lib_python) {
Py_FatalError(
-@@ -700,7 +700,7 @@
+@@ -683,7 +683,7 @@
}
else
wcsncpy(zip_path, _prefix, MAXPATHLEN);
@@ -126,7 +126,7 @@ diff -uar Python-3.5.1.orig/Modules/getpath.c Python-3.5.1/Modules/getpath.c
bufsz = wcslen(zip_path); /* Replace "00" with version */
zip_path[bufsz - 6] = VERSION[0];
zip_path[bufsz - 5] = VERSION[2];
-@@ -712,7 +712,7 @@
+@@ -695,7 +695,7 @@
fprintf(stderr,
"Could not find platform dependent libraries <exec_prefix>\n");
wcsncpy(exec_prefix, _exec_prefix, MAXPATHLEN);
@@ -135,22 +135,25 @@ diff -uar Python-3.5.1.orig/Modules/getpath.c Python-3.5.1/Modules/getpath.c
}
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
-diff -uar Python-3.5.1.orig/configure Python-3.5.1/configure
---- Python-3.5.1.orig/configure 2015-12-07 03:39:11.000000000 +0200
-+++ Python-3.5.1/configure 2015-12-14 21:27:46.089400598 +0200
-@@ -14464,7 +14464,7 @@
- $as_echo "$LDVERSION" >&6; }
+diff -uar Python-3.6.0.orig/configure Python-3.6.0/configure
+--- Python-3.6.0.orig/configure 2016-12-23 04:21:22.000000000 +0200
++++ Python-3.6.0/configure 2016-12-27 23:31:34.568609672 +0200
+@@ -14896,9 +14896,9 @@
--LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
-+LIBPL='$(prefix)'"/lib64/python${VERSION}/config-${LDVERSION}"
+ if test x$PLATFORM_TRIPLET = x; then
+- LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
++ LIBPL='$(prefix)'"/lib64/python${VERSION}/config-${LDVERSION}"
+ else
+- LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
++ LIBPL='$(prefix)'"/lib64/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
+ fi
- # Check whether right shifting a negative integer extends the sign bit
-diff -uar Python-3.5.1.orig/setup.py Python-3.5.1/setup.py
---- Python-3.5.1.orig/setup.py 2015-12-07 03:39:11.000000000 +0200
-+++ Python-3.5.1/setup.py 2015-12-14 21:27:46.090400632 +0200
-@@ -469,7 +469,7 @@
+diff -uar Python-3.6.0.orig/setup.py Python-3.6.0/setup.py
+--- Python-3.6.0.orig/setup.py 2016-12-23 04:21:22.000000000 +0200
++++ Python-3.6.0/setup.py 2016-12-27 23:34:22.210345509 +0200
+@@ -491,7 +491,7 @@
# directories (i.e. '.' and 'Include') must be first. See issue
# 10520.
if not cross_compiling:
@@ -159,7 +162,7 @@ diff -uar Python-3.5.1.orig/setup.py Python-3.5.1/setup.py
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
# only change this for cross builds for 3.3, issues on Mageia
if cross_compiling:
-@@ -750,11 +750,11 @@
+@@ -782,11 +782,11 @@
elif curses_library:
readline_libs.append(curses_library)
elif self.compiler.find_library_file(lib_dirs +
@@ -173,7 +176,7 @@ diff -uar Python-3.5.1.orig/setup.py Python-3.5.1/setup.py
extra_link_args=readline_extra_link_args,
libraries=readline_libs) )
else:
-@@ -791,8 +791,8 @@
+@@ -823,8 +823,8 @@
if krb5_h:
ssl_incs += krb5_h
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,