summaryrefslogtreecommitdiffstats
path: root/python/python3/patches/python3.x86_64.diff
diff options
context:
space:
mode:
author Audrius Kažukauskas2014-05-29 01:24:38 +0200
committer Willy Sudiarto Raharjo2014-05-29 01:24:38 +0200
commit99ccbd65b57bb09b1feff1a611655163377144da (patch)
treedc630092e4173052f1409ae4c23b53be8b8fc925 /python/python3/patches/python3.x86_64.diff
parent81efe6c63650341e1604ba158268b131e9801755 (diff)
downloadslackbuilds-99ccbd65b57bb09b1feff1a611655163377144da.tar.gz
python/python3: Updated for version 3.4.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3/patches/python3.x86_64.diff')
-rw-r--r--python/python3/patches/python3.x86_64.diff62
1 files changed, 25 insertions, 37 deletions
diff --git a/python/python3/patches/python3.x86_64.diff b/python/python3/patches/python3.x86_64.diff
index 8fced1404b..1c4aa6e0ef 100644
--- a/python/python3/patches/python3.x86_64.diff
+++ b/python/python3/patches/python3.x86_64.diff
@@ -1,6 +1,6 @@
-diff -uar Python-3.4.0.orig/Lib/distutils/command/install.py Python-3.4.0/Lib/distutils/command/install.py
---- Python-3.4.0.orig/Lib/distutils/command/install.py 2014-03-17 04:31:29.000000000 +0200
-+++ Python-3.4.0/Lib/distutils/command/install.py 2014-03-29 12:41:46.360404163 +0200
+diff -uar Python-3.4.1.orig/Lib/distutils/command/install.py Python-3.4.1/Lib/distutils/command/install.py
+--- Python-3.4.1.orig/Lib/distutils/command/install.py 2014-05-19 08:19:37.000000000 +0300
++++ Python-3.4.1/Lib/distutils/command/install.py 2014-05-25 16:53:03.729600470 +0300
@@ -44,15 +44,15 @@
INSTALL_SCHEMES = {
@@ -21,9 +21,9 @@ diff -uar Python-3.4.0.orig/Lib/distutils/command/install.py Python-3.4.0/Lib/di
'headers': '$base/include/python/$dist_name',
'scripts': '$base/bin',
'data' : '$base',
-diff -uar Python-3.4.0.orig/Lib/distutils/sysconfig.py Python-3.4.0/Lib/distutils/sysconfig.py
---- Python-3.4.0.orig/Lib/distutils/sysconfig.py 2014-03-17 04:31:29.000000000 +0200
-+++ Python-3.4.0/Lib/distutils/sysconfig.py 2014-03-29 12:41:46.360404163 +0200
+diff -uar Python-3.4.1.orig/Lib/distutils/sysconfig.py Python-3.4.1/Lib/distutils/sysconfig.py
+--- Python-3.4.1.orig/Lib/distutils/sysconfig.py 2014-05-19 08:19:38.000000000 +0300
++++ Python-3.4.1/Lib/distutils/sysconfig.py 2014-05-25 16:53:03.729600470 +0300
@@ -142,7 +142,7 @@
if os.name == "posix":
@@ -33,9 +33,9 @@ diff -uar Python-3.4.0.orig/Lib/distutils/sysconfig.py Python-3.4.0/Lib/distutil
if standard_lib:
return libpython
else:
-diff -uar Python-3.4.0.orig/Lib/site.py Python-3.4.0/Lib/site.py
---- Python-3.4.0.orig/Lib/site.py 2014-03-17 04:31:30.000000000 +0200
-+++ Python-3.4.0/Lib/site.py 2014-03-29 12:45:39.339784221 +0200
+diff -uar Python-3.4.1.orig/Lib/site.py Python-3.4.1/Lib/site.py
+--- Python-3.4.1.orig/Lib/site.py 2014-05-19 08:19:38.000000000 +0300
++++ Python-3.4.1/Lib/site.py 2014-05-25 16:53:03.729600470 +0300
@@ -304,13 +304,13 @@
seen.add(prefix)
@@ -52,9 +52,9 @@ diff -uar Python-3.4.0.orig/Lib/site.py Python-3.4.0/Lib/site.py
if sys.platform == "darwin":
# for framework builds *only* we add the standard Apple
# locations.
-diff -uar Python-3.4.0.orig/Lib/sysconfig.py Python-3.4.0/Lib/sysconfig.py
---- Python-3.4.0.orig/Lib/sysconfig.py 2014-03-17 04:31:30.000000000 +0200
-+++ Python-3.4.0/Lib/sysconfig.py 2014-03-29 12:41:46.361404197 +0200
+diff -uar Python-3.4.1.orig/Lib/sysconfig.py Python-3.4.1/Lib/sysconfig.py
+--- Python-3.4.1.orig/Lib/sysconfig.py 2014-05-19 08:19:38.000000000 +0300
++++ Python-3.4.1/Lib/sysconfig.py 2014-05-25 16:53:03.729600470 +0300
@@ -20,10 +20,10 @@
_INSTALL_SCHEMES = {
@@ -100,21 +100,9 @@ diff -uar Python-3.4.0.orig/Lib/sysconfig.py Python-3.4.0/Lib/sysconfig.py
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
'data': '{userbase}',
-diff -uar Python-3.4.0.orig/Lib/venv/__init__.py Python-3.4.0/Lib/venv/__init__.py
---- Python-3.4.0.orig/Lib/venv/__init__.py 2014-03-17 04:31:30.000000000 +0200
-+++ Python-3.4.0/Lib/venv/__init__.py 2014-03-29 12:41:46.361404197 +0200
-@@ -133,7 +133,7 @@
- else:
- binname = 'bin'
- incpath = 'include'
-- libpath = os.path.join(env_dir, 'lib', 'python%d.%d' % sys.version_info[:2], 'site-packages')
-+ libpath = os.path.join(env_dir, 'lib64', 'python%d.%d' % sys.version_info[:2], 'site-packages')
- context.inc_path = path = os.path.join(env_dir, incpath)
- create_if_needed(path)
- create_if_needed(libpath)
-diff -uar Python-3.4.0.orig/Makefile.pre.in Python-3.4.0/Makefile.pre.in
---- Python-3.4.0.orig/Makefile.pre.in 2014-03-17 04:31:30.000000000 +0200
-+++ Python-3.4.0/Makefile.pre.in 2014-03-29 12:41:46.361404197 +0200
+diff -uar Python-3.4.1.orig/Makefile.pre.in Python-3.4.1/Makefile.pre.in
+--- Python-3.4.1.orig/Makefile.pre.in 2014-05-19 08:19:39.000000000 +0300
++++ Python-3.4.1/Makefile.pre.in 2014-05-25 16:53:03.729600470 +0300
@@ -115,7 +115,7 @@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
@@ -124,9 +112,9 @@ diff -uar Python-3.4.0.orig/Makefile.pre.in Python-3.4.0/Makefile.pre.in
ABIFLAGS= @ABIFLAGS@
# Detailed destination directories
-diff -uar Python-3.4.0.orig/Modules/getpath.c Python-3.4.0/Modules/getpath.c
---- Python-3.4.0.orig/Modules/getpath.c 2014-03-17 04:31:31.000000000 +0200
-+++ Python-3.4.0/Modules/getpath.c 2014-03-29 12:58:32.943849510 +0200
+diff -uar Python-3.4.1.orig/Modules/getpath.c Python-3.4.1/Modules/getpath.c
+--- Python-3.4.1.orig/Modules/getpath.c 2014-05-19 08:19:39.000000000 +0300
++++ Python-3.4.1/Modules/getpath.c 2014-05-25 16:53:03.730600494 +0300
@@ -118,8 +118,8 @@
#endif
@@ -165,10 +153,10 @@ diff -uar Python-3.4.0.orig/Modules/getpath.c Python-3.4.0/Modules/getpath.c
}
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
-diff -uar Python-3.4.0.orig/configure Python-3.4.0/configure
---- Python-3.4.0.orig/configure 2014-03-17 04:31:31.000000000 +0200
-+++ Python-3.4.0/configure 2014-03-29 14:11:12.338969032 +0200
-@@ -13953,7 +13953,7 @@
+diff -uar Python-3.4.1.orig/configure Python-3.4.1/configure
+--- Python-3.4.1.orig/configure 2014-05-19 08:19:40.000000000 +0300
++++ Python-3.4.1/configure 2014-05-25 16:53:03.731600519 +0300
+@@ -13930,7 +13930,7 @@
$as_echo "$LDVERSION" >&6; }
@@ -177,9 +165,9 @@ diff -uar Python-3.4.0.orig/configure Python-3.4.0/configure
# Check whether right shifting a negative integer extends the sign bit
-diff -uar Python-3.4.0.orig/setup.py Python-3.4.0/setup.py
---- Python-3.4.0.orig/setup.py 2014-03-17 04:31:31.000000000 +0200
-+++ Python-3.4.0/setup.py 2014-03-29 12:41:46.362404227 +0200
+diff -uar Python-3.4.1.orig/setup.py Python-3.4.1/setup.py
+--- Python-3.4.1.orig/setup.py 2014-05-19 08:19:40.000000000 +0300
++++ Python-3.4.1/setup.py 2014-05-25 16:53:03.732600546 +0300
@@ -445,7 +445,7 @@
# directories (i.e. '.' and 'Include') must be first. See issue
# 10520.