summaryrefslogtreecommitdiffstats
path: root/python/python3/patches/python3.x86_64.diff
diff options
context:
space:
mode:
author Audrius Kažukauskas2015-10-25 19:43:53 +0100
committer Willy Sudiarto Raharjo2015-10-31 02:33:28 +0100
commit34becae63e7c599fdfbc5aa6bb27bd256b38bdec (patch)
tree1992454624fe5494e2d980ae71ae663afbeb9520 /python/python3/patches/python3.x86_64.diff
parent2cb182b1cca673e6191e525097015664a02534a0 (diff)
downloadslackbuilds-34becae63e7c599fdfbc5aa6bb27bd256b38bdec.tar.gz
python/python3: Updated for version 3.5.0.
Thanks to Richard Hoyle. Signed-off-by: Audrius Kažukauskas <audrius@neutrino.lt>
Diffstat (limited to 'python/python3/patches/python3.x86_64.diff')
-rw-r--r--python/python3/patches/python3.x86_64.diff87
1 files changed, 40 insertions, 47 deletions
diff --git a/python/python3/patches/python3.x86_64.diff b/python/python3/patches/python3.x86_64.diff
index 6d03183149..cf61af655a 100644
--- a/python/python3/patches/python3.x86_64.diff
+++ b/python/python3/patches/python3.x86_64.diff
@@ -1,6 +1,6 @@
-diff -uar Python-3.4.3.orig/Lib/distutils/command/install.py Python-3.4.3/Lib/distutils/command/install.py
---- Python-3.4.3.orig/Lib/distutils/command/install.py 2015-02-25 13:27:44.000000000 +0200
-+++ Python-3.4.3/Lib/distutils/command/install.py 2015-02-25 21:32:54.352351233 +0200
+diff -uar Python-3.5.0.orig/Lib/distutils/command/install.py Python-3.5.0/Lib/distutils/command/install.py
+--- Python-3.5.0.orig/Lib/distutils/command/install.py 2015-09-13 14:41:20.000000000 +0300
++++ Python-3.5.0/Lib/distutils/command/install.py 2015-10-25 16:59:00.429539487 +0200
@@ -29,15 +29,15 @@
INSTALL_SCHEMES = {
@@ -21,10 +21,10 @@ diff -uar Python-3.4.3.orig/Lib/distutils/command/install.py Python-3.4.3/Lib/di
'headers': '$base/include/python/$dist_name',
'scripts': '$base/bin',
'data' : '$base',
-diff -uar Python-3.4.3.orig/Lib/distutils/sysconfig.py Python-3.4.3/Lib/distutils/sysconfig.py
---- Python-3.4.3.orig/Lib/distutils/sysconfig.py 2015-02-25 13:27:44.000000000 +0200
-+++ Python-3.4.3/Lib/distutils/sysconfig.py 2015-02-25 21:32:54.352351233 +0200
-@@ -142,7 +142,7 @@
+diff -uar Python-3.5.0.orig/Lib/distutils/sysconfig.py Python-3.5.0/Lib/distutils/sysconfig.py
+--- Python-3.5.0.orig/Lib/distutils/sysconfig.py 2015-09-13 14:41:21.000000000 +0300
++++ Python-3.5.0/Lib/distutils/sysconfig.py 2015-10-25 16:59:52.157272388 +0200
+@@ -133,7 +133,7 @@
if os.name == "posix":
libpython = os.path.join(prefix,
@@ -33,10 +33,10 @@ diff -uar Python-3.4.3.orig/Lib/distutils/sysconfig.py Python-3.4.3/Lib/distutil
if standard_lib:
return libpython
else:
-diff -uar Python-3.4.3.orig/Lib/site.py Python-3.4.3/Lib/site.py
---- Python-3.4.3.orig/Lib/site.py 2015-02-25 13:27:44.000000000 +0200
-+++ Python-3.4.3/Lib/site.py 2015-02-25 21:32:54.353351252 +0200
-@@ -304,13 +304,13 @@
+diff -uar Python-3.5.0.orig/Lib/site.py Python-3.5.0/Lib/site.py
+--- Python-3.5.0.orig/Lib/site.py 2015-09-13 14:41:21.000000000 +0300
++++ Python-3.5.0/Lib/site.py 2015-10-25 17:02:49.632218047 +0200
+@@ -303,7 +303,7 @@
seen.add(prefix)
if os.sep == '/':
@@ -44,17 +44,10 @@ diff -uar Python-3.4.3.orig/Lib/site.py Python-3.4.3/Lib/site.py
+ sitepackages.append(os.path.join(prefix, "lib64",
"python" + sys.version[:3],
"site-packages"))
- sitepackages.append(os.path.join(prefix, "lib", "site-python"))
else:
- sitepackages.append(prefix)
-- sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
-+ sitepackages.append(os.path.join(prefix, "lib64", "site-packages"))
- if sys.platform == "darwin":
- # for framework builds *only* we add the standard Apple
- # locations.
-diff -uar Python-3.4.3.orig/Lib/sysconfig.py Python-3.4.3/Lib/sysconfig.py
---- Python-3.4.3.orig/Lib/sysconfig.py 2015-02-25 13:27:44.000000000 +0200
-+++ Python-3.4.3/Lib/sysconfig.py 2015-02-25 21:32:54.353351252 +0200
+diff -uar Python-3.5.0.orig/Lib/sysconfig.py Python-3.5.0/Lib/sysconfig.py
+--- Python-3.5.0.orig/Lib/sysconfig.py 2015-09-13 14:41:21.000000000 +0300
++++ Python-3.5.0/Lib/sysconfig.py 2015-10-25 17:06:31.664656808 +0200
@@ -20,10 +20,10 @@
_INSTALL_SCHEMES = {
@@ -100,9 +93,9 @@ diff -uar Python-3.4.3.orig/Lib/sysconfig.py Python-3.4.3/Lib/sysconfig.py
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
'data': '{userbase}',
-diff -uar Python-3.4.3.orig/Makefile.pre.in Python-3.4.3/Makefile.pre.in
---- Python-3.4.3.orig/Makefile.pre.in 2015-02-25 13:27:45.000000000 +0200
-+++ Python-3.4.3/Makefile.pre.in 2015-02-25 21:32:54.354351276 +0200
+diff -uar Python-3.5.0.orig/Makefile.pre.in Python-3.5.0/Makefile.pre.in
+--- Python-3.5.0.orig/Makefile.pre.in 2015-09-13 14:41:23.000000000 +0300
++++ Python-3.5.0/Makefile.pre.in 2015-10-25 17:08:01.439664654 +0200
@@ -120,7 +120,7 @@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
@@ -112,9 +105,9 @@ diff -uar Python-3.4.3.orig/Makefile.pre.in Python-3.4.3/Makefile.pre.in
ABIFLAGS= @ABIFLAGS@
# Detailed destination directories
-diff -uar Python-3.4.3.orig/Modules/getpath.c Python-3.4.3/Modules/getpath.c
---- Python-3.4.3.orig/Modules/getpath.c 2015-02-25 13:27:46.000000000 +0200
-+++ Python-3.4.3/Modules/getpath.c 2015-02-25 21:32:54.354351276 +0200
+diff -uar Python-3.5.0.orig/Modules/getpath.c Python-3.5.0/Modules/getpath.c
+--- Python-3.5.0.orig/Modules/getpath.c 2015-09-13 14:41:24.000000000 +0300
++++ Python-3.5.0/Modules/getpath.c 2015-10-25 17:10:58.101583759 +0200
@@ -118,8 +118,8 @@
#endif
@@ -126,16 +119,16 @@ diff -uar Python-3.4.3.orig/Modules/getpath.c Python-3.4.3/Modules/getpath.c
#endif
#ifndef LANDMARK
-@@ -494,7 +494,7 @@
- _pythonpath = _Py_char2wchar(PYTHONPATH, NULL);
- _prefix = _Py_char2wchar(PREFIX, NULL);
- _exec_prefix = _Py_char2wchar(EXEC_PREFIX, NULL);
-- lib_python = _Py_char2wchar("lib/python" VERSION, NULL);
-+ lib_python = _Py_char2wchar("lib64/python" VERSION, NULL);
+@@ -511,7 +511,7 @@
+ _pythonpath = Py_DecodeLocale(PYTHONPATH, NULL);
+ _prefix = Py_DecodeLocale(PREFIX, NULL);
+ _exec_prefix = Py_DecodeLocale(EXEC_PREFIX, NULL);
+- lib_python = Py_DecodeLocale("lib/python" VERSION, NULL);
++ lib_python = Py_DecodeLocale("lib64/python" VERSION, NULL);
if (!_pythonpath || !_prefix || !_exec_prefix || !lib_python) {
Py_FatalError(
-@@ -683,7 +683,7 @@
+@@ -700,7 +700,7 @@
}
else
wcsncpy(zip_path, _prefix, MAXPATHLEN);
@@ -144,7 +137,7 @@ diff -uar Python-3.4.3.orig/Modules/getpath.c Python-3.4.3/Modules/getpath.c
bufsz = wcslen(zip_path); /* Replace "00" with version */
zip_path[bufsz - 6] = VERSION[0];
zip_path[bufsz - 5] = VERSION[2];
-@@ -695,7 +695,7 @@
+@@ -712,7 +712,7 @@
fprintf(stderr,
"Could not find platform dependent libraries <exec_prefix>\n");
wcsncpy(exec_prefix, _exec_prefix, MAXPATHLEN);
@@ -153,22 +146,22 @@ diff -uar Python-3.4.3.orig/Modules/getpath.c Python-3.4.3/Modules/getpath.c
}
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
-diff -uar Python-3.4.3.orig/configure Python-3.4.3/configure
---- Python-3.4.3.orig/configure 2015-02-25 13:27:46.000000000 +0200
-+++ Python-3.4.3/configure 2015-02-25 21:32:54.358351377 +0200
-@@ -14022,7 +14022,7 @@
+diff -uar Python-3.5.0.orig/configure Python-3.5.0/configure
+--- Python-3.5.0.orig/configure 2015-09-13 14:41:26.000000000 +0300
++++ Python-3.5.0/configure 2015-10-25 17:24:00.325783290 +0200
+@@ -14384,7 +14384,7 @@
$as_echo "$LDVERSION" >&6; }
--LIBPL="${prefix}/lib/python${VERSION}/config-${LDVERSION}"
-+LIBPL="${prefix}/lib64/python${VERSION}/config-${LDVERSION}"
+-LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
++LIBPL='$(prefix)'"/lib64/python${VERSION}/config-${LDVERSION}"
# Check whether right shifting a negative integer extends the sign bit
-diff -uar Python-3.4.3.orig/setup.py Python-3.4.3/setup.py
---- Python-3.4.3.orig/setup.py 2015-02-25 13:27:46.000000000 +0200
-+++ Python-3.4.3/setup.py 2015-02-25 21:32:54.358351377 +0200
-@@ -451,7 +451,7 @@
+diff -uar Python-3.5.0.orig/setup.py Python-3.5.0/setup.py
+--- Python-3.5.0.orig/setup.py 2015-09-13 14:41:26.000000000 +0300
++++ Python-3.5.0/setup.py 2015-10-25 17:35:30.926901801 +0200
+@@ -469,7 +469,7 @@
# directories (i.e. '.' and 'Include') must be first. See issue
# 10520.
if not cross_compiling:
@@ -177,7 +170,7 @@ diff -uar Python-3.4.3.orig/setup.py Python-3.4.3/setup.py
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
# only change this for cross builds for 3.3, issues on Mageia
if cross_compiling:
-@@ -730,11 +730,11 @@
+@@ -750,11 +750,11 @@
elif curses_library:
readline_libs.append(curses_library)
elif self.compiler.find_library_file(lib_dirs +
@@ -191,7 +184,7 @@ diff -uar Python-3.4.3.orig/setup.py Python-3.4.3/setup.py
extra_link_args=readline_extra_link_args,
libraries=readline_libs) )
else:
-@@ -771,8 +771,8 @@
+@@ -791,8 +791,8 @@
if krb5_h:
ssl_incs += krb5_h
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,